lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-12-2010, 12:27 PM   #1
Not Yet Wild
 
Join Date: Oct 2010
Posts: 1
Default 1987 Club Car only runs at top speed

I checked continuity for all micro switches. I found one that was bad. I replaced it with the F&R switch, bypassed the F&R switch with a wire and still have the problem.

While in neutral, l pressed the accelerator pedal slowly and heard each selodoid click begining with the first one on the driver side.

Bill
bill2170 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-12-2010, 02:18 PM   #2
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: 1987 Club Car only runs at top speed

On older carts like yours, even though the solenoids click does not mean they are making internal contact? Check that each one is feeding power through to coils in order?Also resistor coils and connections on board are bad for poor connections so check all for loose, cracked connections.
OLD MEC is offline   Reply With Quote
Unread 10-13-2010, 07:38 AM   #3
Gone Wild
 
Join Date: Feb 2009
Location: Not sure yet
Posts: 500
Default Re: 1987 Club Car only runs at top speed

Does it take off at top speed right from the start? or does it click thru the first 4 solenoids first, then run like a bat out of hell?
FIXEROFCARTS is offline   Reply With Quote
Unread 04-25-2012, 06:23 PM   #4
Not Yet Wild
 
Join Date: Apr 2012
Posts: 2
Default Re: 1987 Club Car only runs at top speed

I would like to get in on this one! My 85 36v club car goes through all four and then finally runs on the last only! What's with that?
Bdb117 is offline   Reply With Quote
Unread 04-26-2012, 01:23 AM   #5
Not Yet Wild
 
SD70ACe's Avatar
E-Z-GO
 
Join Date: Dec 2011
Location: Peachtree City, GA
Posts: 28
Default Re: 1987 Club Car only runs at top speed

I had a similar issue on my 87, except I was missing 1st speed. I swapped out the 1st speed solenoid with one of the other ones but it still didn't work. Turned out it was the microswitch that was bad, so I just replaced the whole assembly. I have since replaced all 5 solenoids, all 3 resistors, the resistor brackets and the buss bar. Now it runs like a champ and has a little more pep too!
SD70ACe is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
1985 G1 Runs fine low speed , high speed run for a mile then fall on its face Gas Yamaha
2002 CC DS runs at half speed Electric Club Car
82 Club car only runs at full speed Electric Club Car
1987 wire diagram insde speed box? Electric Club Car
1987 Club Car Speed Switch Assembly Electric Club Car


All times are GMT -5. The time now is 09:54 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.