lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-17-2010, 09:29 PM   #1
Gone Wild
 
Colbyntx's Avatar
Club Car
 
Join Date: Jun 2010
Location: East Texas
Posts: 602
Default What am I missing?????

I am putting togather a 95 DS that was in pieces when I got it so I can roll it off my trailer. I put the rear end on this evening but I think I might be missing a part. I don't see a bracket to put the brake cable into. There is a hole in the plate that the U bolt goes through but I don't thing this is it because it would put the cable at a 90 deg angle. Any help would be great!

Thanks
Attached Images
File Type: jpg cart20.jpg (46.5 KB, 23 views)
Colbyntx is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-17-2010, 10:12 PM   #2
Yamahaulin' CC Rider
 
SteveRand's Avatar
Mixed Breed
 
Join Date: Jul 2010
Location: Altadena, CA
Posts: 684
Default Re: What am I missing?????

The brake cables go through holes in the brackets under the leaf springs, and are retained with c-clips. The u-bolts do pass through the brackets.

The gray shaded part in the diagram here is the bracket. The one in your pic is not the right part. The other is a pic of mine...

Hope this helps!
Attached Images
File Type: jpg Brake Assembly.jpg (75.8 KB, 22 views)
File Type: jpg Brake Cable Mount.jpg (91.8 KB, 14 views)
SteveRand is offline   Reply With Quote
Unread 10-18-2010, 10:22 AM   #3
Gone Wild
 
Colbyntx's Avatar
Club Car
 
Join Date: Jun 2010
Location: East Texas
Posts: 602
Default Re: What am I missing?????

Steve,

Thanks for the pic! I have the wrong spring plates. Oh well, it is not going to be running for a while so who needs brakes! I guess I will look for a set.
Colbyntx is offline   Reply With Quote
Unread 10-18-2010, 10:57 PM   #4
Yamahaulin' CC Rider
 
SteveRand's Avatar
Mixed Breed
 
Join Date: Jul 2010
Location: Altadena, CA
Posts: 684
Default Re: What am I missing?????

No problem, glad to help. The "Carts and parts for sale" section will probably have what you need.

Keep us posted on the status of your project, and as always, we love lots of pics!
SteveRand is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
obc was missing...how do I know which one to get... Electric Club Car
Fantastic! Looks like I'm also missing the... Gas Club Car
Missing Gas EZGO


All times are GMT -5. The time now is 06:50 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.