lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-25-2010, 10:35 AM   #1
Not Yet Wild
 
Join Date: Oct 2010
Posts: 10
Default Did I kill my cart

Hi all,

I was in the process of adding an alltrax dcx500 controller to my 2001 regen 2 cart. Before I started I disconnected the battery cables, put the car in tow, and turned ignition off. I made the mistake of drilling through the obc to fit a 2 gauge cable through and now reAlize that was a big mistake but now the cart is completely dead as I reconnected. The batteries are 6 months old and had been fully charged prior but I also accidentally touch positive to negative on one battery while running caBle which caused a sparked bit since nothing was connected hopefully it didn't burn something out.

Right now my charger won't charge and nothing at all is working. Can someone give me some guidance on how to get started narrowing it down?

Thanks
samg713 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-25-2010, 10:41 AM   #2
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,060
Default Re: Did I kill my cart

Check the fuse behind the charge receptacle... One is a glass encased big suka & one is a 3/8 amp in a yellow in-line holder.... might be a second inline yellow holder at the solenoid?
scottyb is offline   Reply With Quote
Unread 10-25-2010, 10:44 AM   #3
Gone Wild
Club Car
 
Join Date: Jan 2010
Location: Houston, Texas
Posts: 179
Default Re: Did I kill my cart

At the very least you need a new OBC as yours is now ruined. Until it is replaced the charger will not work and the OBC might be your sole issue. It will be hard to tell if anything else was damaged until the OBC is replaced. Next time leave the factory wire running through the OBC and just run the new heavier wire around the OBC and connect them both at the battery, this way the OBC is still sensing the current from the original wire.
dtkana is offline   Reply With Quote
Unread 10-25-2010, 11:01 AM   #4
Not Yet Wild
 
Join Date: Oct 2010
Posts: 10
Default Re: Did I kill my cart

Ok, thanks. The yellow fuse was ok and I will look for the other one and order the computer and pray.
samg713 is offline   Reply With Quote
Unread 10-25-2010, 11:18 AM   #5
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,060
Default Re: Did I kill my cart

There is a bypass for the negative side of the OBC. I believe if you jumper the Neg. feed to the solenoid and it runs the obc is bad.... lets see what other's say about this.
scottyb is offline   Reply With Quote
Unread 10-25-2010, 12:10 PM   #6
Gone Wild
Club Car
 
Join Date: Jan 2010
Location: Houston, Texas
Posts: 179
Default Re: Did I kill my cart

I once bypassed the relay in my charger which eliminates the OBC. The instructions are on this site somewhere. Try searching, but I am quite certain the OBC is bad after having a whole drilled through it.
dtkana is offline   Reply With Quote
Unread 10-25-2010, 12:16 PM   #7
Not Yet Wild
 
Join Date: Oct 2010
Posts: 10
Default Re: Did I kill my cart

The hole I drilled is the existing hole for the battery cabe I dissent know it was important but I just ordered a new one and I will try to bypass it anyway to see what happens
samg713 is offline   Reply With Quote
Unread 10-25-2010, 01:30 PM   #8
Not Yet Wild
 
Join Date: Oct 2010
Posts: 2
Default Re: Did I kill my cart

I'm no expert, but I made a similar mistake and drilled a hole partially through the wiring harness. I took it into a local shop and they were able to reconstruct the harness.
ceocu is offline   Reply With Quote
Unread 10-26-2010, 06:13 PM   #9
Gone Wild
 
Jim C's Avatar
Club Car
 
Join Date: Oct 2008
Location: Wildwood, FL
Posts: 697
Default Re: Did I kill my cart

Its my understanding that the sensor wires are wrapped around the hole in the obc, so if you enlarge it with a drill there won't be any fixing it.

The new obc will likely come with a new cable. Leave it and put your old cable back on (as dtkana said) bypassing the obc.
Jim C is offline   Reply With Quote
Unread 10-26-2010, 07:37 PM   #10
Gone Wild
 
Fishing Dude's Avatar
Club Car
 
Join Date: Jul 2008
Location: Slums of Lake Erie
Posts: 3,722
Default Re: Did I kill my cart

I think you only wounded it, so take you hp riffle and shoot it through the OBC, then sell to someone for glue. I would pay you 20 bucks for it then. LOL

You can put a new wire through OBC where you removed it, leaving the new wire in place. Do not drill out as this will ruin the OBC.
Fishing Dude is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Kill Switch ? Electric EZGO
96 cc kill switch Gas Club Car
How do you kill the rev. beeping? Electric Club Car
Somebodys bow kill Hunting and Fishing
Bobcat bow kill Hunting and Fishing


All times are GMT -5. The time now is 04:18 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.