lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-28-2010, 02:54 PM   #1
Not Yet Wild
 
Join Date: Sep 2010
Posts: 51
Default No go on ezgo-club conversion

I have just finished wiring my ezgo body w/ a 5K-0K pb-6, which goes into a 700a logisystems cont. attached to a GEd380 motor and club rearend. I turn key on, get 46v (old batts-getting new ones real soon) across the 48v hd soln. I have power from the Batt(-) to the B+ on controller, which goes to A1 on motor. I checked voltage at the F&R lugs and have 46v to the A1 and M-, i assume that voltage is going through motor. Can anyone shed any light on this.
la-boy is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-28-2010, 03:54 PM   #2
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: No go on ezgo-club conversion

With only 46 volts on 48 volt battery pack you only have about ( 10% ) of charge far below being able to operate motor even with wheels off ground SHOULD BE 50.6 volts so that may be problem? What motor do you have? Is it series or is it shunt? I dont have access to GE motor info nor Logistic controller info so just wondering? Did this motor work with Logistic controller before starting change over, or is this all different parts added?
OLD MEC is offline   Reply With Quote
Unread 10-28-2010, 11:18 PM   #3
Not Yet Wild
 
Join Date: Sep 2010
Posts: 51
Default Re: No go on ezgo-club conversion

Was told that it would work, ur right it may be a voltage prob.(not enough to the cont-motor) I did charge the pack up to 52.??? and it stayed there for a little while but did go back to 46v. while at the 52.???v ther was no change in the outcome of having the voltage reading at the F&R. thanks for any advice......la-boy. alittle lost in the DC World.
la-boy is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Club Car conversion Lifted Golf Carts
ezgo-club conversion Electric Club Car
Club Car controller conversion Extreme DC!
club car to ezgo conversion Electric EZGO
ezgo gas to club car conversion Gas Club Car


All times are GMT -5. The time now is 08:07 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.