lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-29-2010, 09:35 AM   #1
Not Yet Wild
 
Join Date: Oct 2010
Posts: 3
Cool neg- cable sparks when reconnecting

I have a 2005 48volt club car the battery neg cable has been disconnected for a while, when i went to reconnect with the switch on run it it sparks is this right.It does not spark on tow.

Thanks

Last edited by brit54; 10-29-2010 at 09:45 AM.. Reason: more info
brit54 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-29-2010, 11:28 AM   #2
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: neg- cable sparks when reconnecting

I CANNOT STRESS ENOUGH THAT YOU MUST READ YOUR OWNERS MANUAL BEFORE ATTEMPTING ANY WIRING CONNECTIONS AND DISCONNECTIONS? To keep from damaging sensative electronic componants ( Micros, Controller, F&R Control, MCOR, OBC, Etc ) ALL SWITCHES must be turned "OFF" and ( TOW-RUN SWITCH MUST REMAIN IN TOW POSITION UNTIL AFTER ALL CONNECTIONS HAVE BEEN COMPLETED ). By turning key switch on and sparking battery connections you are allowing high voltage surges to flow to all parts of system connected doing possible MAJOR damage? By switching to ( TOW ) you have disconnected circuit so no spark is correct?
I wish you luck and hope that your expensive electronics have not been damaged??
OLD MEC is offline   Reply With Quote
Unread 10-29-2010, 11:55 AM   #3
Not Yet Wild
 
Join Date: Oct 2010
Posts: 3
Default Re: neg- cable sparks when reconnecting

Everything was off, but tow run switch was moved to run and i did not notice, it just seems odd that with key switch off,forward reverse in neutral there's a current draw. I have not yet reconnected as i was unsure why this was.

Thanks Peter
brit54 is offline   Reply With Quote
Unread 10-29-2010, 01:25 PM   #4
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: neg- cable sparks when reconnecting

By having switch in RUN you were powering up a portion of solenoid circuit ( Precharge Resistor ) and possibly a portion of solid state controller B PLUS, voltage reducer, etc, when completing battery pack connections.
OLD MEC is offline   Reply With Quote
Unread 10-29-2010, 06:01 PM   #5
What the.....?
 
lockman1's Avatar
Club Car
 
Join Date: Jan 2007
Location: N.E. Wisconsin
Posts: 11,369
Default Re: neg- cable sparks when reconnecting

In other words kids...

ALWAYS put your cart in TOW before doing ANY service work!

lockman1 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
97 EZGO Sparks Electric EZGO
sparks Electric EZGO
club car sparks Electric Club Car
Sparks and Smoke Electric Club Car
Reconnecting an hour meter Gas EZGO


All times are GMT -5. The time now is 09:17 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.