lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-04-2010, 02:03 PM   #1
Not Yet Wild
 
Join Date: Nov 2010
Posts: 3
Default Cart won't run with petal to floor

New to electric golf carts and I have a question. I got a 2001 Club Car last year and it has worked fine up to now. What happens when I push the petal to the floor is that it just shudders and won't move. I have found that if I just barely push it, it will run. I lifted the rear end up and this doesn't happen, it runs fine. I work for a non profit organization and money it tight and I can't afford to take it to be repaired so I must do as much as I can. I just need some direction.
Thanks.
Frank K is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-04-2010, 03:28 PM   #2
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,912
Default Re: Cart won't run with petal to floor

Welcome to BGW


Next time it happens wiggle your F/R switch back and forth with the go pedal pushed a bit and see if it jumps. If it does you MIGHT be able to take it apart and repair it. Look at the back of the switch and see if its been hot. Check all the cables one at time and make sure they are clean and tight. I don't mean just wiggle the cables, loosen the nuts, clean and re-install....again, one at a time. Check each cell and make sure they have water. (distilled water only) It could be any number of things but I'd start there.
roady89 is offline   Reply With Quote
Unread 11-04-2010, 07:25 PM   #3
Not Yet Wild
 
Join Date: Nov 2010
Posts: 3
Default Re: Cart won't run with pedal to floor

Ok make that the pedal.
Frank K is offline   Reply With Quote
Unread 11-06-2010, 06:45 PM   #4
Not Yet Wild
 
Join Date: Nov 2010
Posts: 3
Default Re: Cart won't run with petal to floor

Quote:
Originally Posted by roady89 View Post
Welcome to BGW


Next time it happens wiggle your F/R switch back and forth with the go pedal pushed a bit and see if it jumps. If it does you MIGHT be able to take it apart and repair it. Look at the back of the switch and see if its been hot. Check all the cables one at time and make sure they are clean and tight. I don't mean just wiggle the cables, loosen the nuts, clean and re-install....again, one at a time. Check each cell and make sure they have water. (distilled water only) It could be any number of things but I'd start there.
Newer batteries with plenty of water. Tried wiggling didn't jump. Doesn't look as though it has been hot. All bad cables have been replaced and the rest taken off and cleaned. Still doing the same thing.
Frank K is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Floor Mat? Ideas? Different? Electric Club Car
81 g1 floor mats Gas Yamaha
Cart runs with key off and petal in off position Electric EZGO
new floor pan? Electric EZGO
Floor Mats? Golf Carts and Parts


All times are GMT -5. The time now is 01:01 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.