lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-17-2010, 11:36 AM   #1
Not Yet Wild
 
Join Date: Nov 2010
Posts: 2
Default Not charging

I have a 94 club car and the charger will not come on. The charger works on another car. I tryed another charger and have the same issue.
redfish23 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-17-2010, 12:10 PM   #2
Not Yet Wild
 
ackjay's Avatar
Club Car
 
Join Date: Oct 2010
Location: Greensburg, Indiana
Posts: 27
Default Re: Not charging

Check the voltage across your entire series. The charger will not come on til there is a certian amount of volts in the series.
If you have a 6 volt charger, charge each battery individually for about an hour, then plug your charger back in.
If all you have is a 12 volt charger, charge them in pairs for about an hour as well. I had the same issue with mine when I first got it.

Hope this helps.
ackjay is offline   Reply With Quote
Unread 11-17-2010, 10:19 PM   #3
Not Yet Wild
 
Join Date: Nov 2010
Posts: 2
Default Re: Not charging

Thanks that worked, I have foward but now I dont have reverse
redfish23 is offline   Reply With Quote
Unread 11-18-2010, 06:48 AM   #4
Not Yet Wild
 
ackjay's Avatar
Club Car
 
Join Date: Oct 2010
Location: Greensburg, Indiana
Posts: 27
Default Re: Not charging

I have not gotten familiar with my forward reverse switch yet, so I'm afraid I can't really offer any help in that area. I know my CC is a '93 and my switch looks very similar to this:



This switch appears to be in the neutral position, so putting the car in reverse would turn this switch clockwise from this angle. I would start by checking/cleaning all the terminals attached to this. Of course, this image doesn't show the 4 or 6 ga cables attached to the back of those copper nuts.
(this is my first time trying to post an image, hope it works)

Good luck with the cart.
ackjay is offline   Reply With Quote
Unread 11-18-2010, 07:13 AM   #5
Gone Wild
 
rabbitreborn's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Central Florida
Posts: 2,704
Default Re: Not charging

I believe 94 was a resistor coil based car. If so, there should be 1 wire coming from the main 36v positive to the bottom lug of the F&R on the driver's side and a second power wire (usually green) coming from one of the 2 middle batteries to the bottom lug on the passenger's side of the F&R. The second main power wire is what would give you power for Reverse. Check to make sure this wire is connected and note which battery it is connected to.
rabbitreborn is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
par car not charging Gas Columbia ParCar
Charging Electric Club Car
? on charging my TXT Electric EZGO
charging Electric Club Car
36v Charging on '05 PDS Electric EZGO


All times are GMT -5. The time now is 06:47 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.