lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-14-2010, 10:00 PM   #1
Not Yet Wild
Yamaha
 
Join Date: Dec 2010
Location: Surrey B.C. Canada
Posts: 22
Question Not charging

Does the charger make noise when it is working? Is there a sensor or____? on the cart that tells the charger to turn on?
crabbydale is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-14-2010, 10:03 PM   #2
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 7,961
Default Re: Not charging

We're gonna need more information about the vehicle than you specify. A serial number would be great to begin with if you can get it for us.

EDIT: Just saw your other post...... It's a 95 48V Series cart.

Yes the charger will have a slight hum when it's charging and the needle on the ammeter will move up towards the max at first and eventually taper down to nothing and turn off. If it's not doing that you may have either a problem with the charger itself or the on-board computer of the golf car. With yours being a 1995 you may have the famous black computer on it. If you do, please do yourself a favor and replace it ASAP with a 101800606 model as the black ones were crap from day one and I've NEVER seen one that worked right. Consider yourself lucky if it's already been changed. FYI in case you didn't know, the OBC is the small square box hanging under the rear body just behind the battery compartment. It's got the main negative wire of the battery pack running right through the middle of it.
TahoeDawgZ71 is offline   Reply With Quote
Unread 12-14-2010, 10:06 PM   #3
Not Yet Wild
Club Car
 
Join Date: Mar 2009
Location: Northern Wisconsin
Posts: 48
Default Re: Not charging

Make sure you have power where you plug it in. Mine was tripped one time and I was looking at everything else except that.
sb2bb is offline   Reply With Quote
Unread 12-14-2010, 10:46 PM   #4
Not Yet Wild
Yamaha
 
Join Date: Dec 2010
Location: Surrey B.C. Canada
Posts: 22
Default Re: Not charging

A9536-458333
crabbydale is offline   Reply With Quote
Unread 12-14-2010, 10:50 PM   #5
Not Yet Wild
Yamaha
 
Join Date: Dec 2010
Location: Surrey B.C. Canada
Posts: 22
Default Re: Not charging

Lol My extension cord has a light on the end
Thanx
crabbydale is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
No charging help please. Gas Club Car
? on charging my TXT Electric EZGO
Charging Electric EZGO
charging Electric Club Car
36v Charging on '05 PDS Electric EZGO


All times are GMT -5. The time now is 04:19 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.