lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-26-2010, 08:24 PM   #1
Not Yet Wild
 
Join Date: Nov 2010
Posts: 9
Default Not taking a charge/ batteries?

For the last several weeks I have been rebuilding a 2000 club car DS 48V. This car had been drowned by Hurricane Ike 2 years ago. I have replaced the motor, controller, solenoid and lots of wiring. After I got the wiring done, I cleaned up the batteries and plugged the charger into the cart. The charger came on and the batteries took a charge. When the charger shut down I had a voltage reading of 54V. I jacked the cart up, turned it on, gave it the throttle and the wheels were spinning. At this point I started going through the rest of the car, brakes, steering, etc. I lowered the cart to give it a test run. I put it in reverse, the cart backs up, put it in forward and it barely moved. I checked my batteries and got a reading of 34V. I put the charger back on and this time it would not take a charge. I tried resetting the OBC with no luck. Any ideas? Sorry for the long post, I am just trying to give all the details.
Ken
kfoyt is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-26-2010, 08:34 PM   #2
Moderator
 
rib33024's Avatar
E-Z-GO
 
Join Date: Apr 2009
Location: FT Lauderdale FL.
Posts: 13,151
Default Re: Not taking a charge/ batteries?

Welcome to BGW

how old, and what kind of batteries are they??

did you check the water in the batteries before charging??

can you give us some volt reading's of each battery??

I know you don't want to hear it but I think it's time for new batteries
rib33024 is online now   Reply With Quote
Unread 12-26-2010, 09:15 PM   #3
Not Yet Wild
 
Join Date: Nov 2010
Posts: 9
Default Re: Not taking a charge/ batteries?

Boy, I feel like a D A. I had pulled one of the batteries today to hook up the throttle linkage and had put the battery in back wards, thus hooking it up wrong. Thanks for your quick replay, the cart is running great now.
Ken
kfoyt is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Recharging Batteries---so charge recognizes batteries!! Electric EZGO
Is there a way to charge 8V batteries ind? Electric Club Car
club car batteries not taking full charge Electric Club Car
1985 EZGO not taking charge Electric EZGO
Changed batteries/batteries won't charge Electric Club Car


All times are GMT -5. The time now is 09:15 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.