lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-29-2011, 07:21 PM   #1
Not Yet Wild
Club Car
 
Join Date: Jul 2009
Location: South Carolina
Posts: 19
Default 97 regen motor speed sensor

I've just upgraded a gen1 to gen2 1997 club car regen and the dynamic braking and regen does not work. I suspect the motor speed sensor, but am having trouble locating that part. Any suggestions??
greyroots is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-29-2011, 09:52 PM   #2
Gone Wild
 
golfcarfixer's Avatar
Club Car
 
Join Date: Sep 2009
Location: DELAWARE
Posts: 2,656
Default Re: 97 regen motor speed sensor

When you did that you did away with 1 solenoid right?
golfcarfixer is offline   Reply With Quote
Unread 01-30-2011, 08:36 AM   #3
Not Yet Wild
Club Car
 
Join Date: Jul 2009
Location: South Carolina
Posts: 19
Default Re: 97 regen motor speed sensor

When the original controller fried,I contacted FSIP. They sent me a new controller with a converting wire harness. In that there were no instructions to remove relay. I'm kinda new and no real fan of regen. This controller is sending 4.5volts to one side of the speed sensor and 11plus volts to the other side and 48volts to the center. I dont get it. Thank you for responding
greyroots is offline   Reply With Quote
Unread 01-30-2011, 10:56 AM   #4
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: 97 regen motor speed sensor

Are U trying to slow the cart back down,
a lot of people come on here , wanting to figure out how to bypass the reagen function !
GLEEMO is offline   Reply With Quote
Unread 01-30-2011, 01:18 PM   #5
Not Yet Wild
Club Car
 
Join Date: Jul 2009
Location: South Carolina
Posts: 19
Default Re: 97 regen motor speed sensor

Its an elderly couples cart,severely neglected.The brakes were dragging badly which probably ate the old controller,they also have back seat and trailer hitch..scary!Just trying to free it up and get it rolling for these folks.Probably heading toward a charity case.OJT?
greyroots is offline   Reply With Quote
Unread 01-30-2011, 03:47 PM   #6
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: 97 regen motor speed sensor

Thats good to help people out, If U don't make a penny , U'll be paid in karma


What U need is the trouble shooting section 21 in the 97 CC service manual.
I have it in a hard copy but that does not help , perhaps someoneon here has it in PDF
GLEEMO is offline   Reply With Quote
Unread 01-31-2011, 10:34 AM   #7
Not Yet Wild
Club Car
 
Join Date: Jul 2009
Location: South Carolina
Posts: 19
Default Re: 97 regen motor speed sensor

I have the 95/96 service manual. So far the regen diagram looks to me like the wiring scheme on this cart.In test 40 it appears the controller is sending 4.63vdc to green and 12vdc to red and it looks like the want that to be the same on both sides.Makes me think I have a valid question for the remanufacturer...FSIP. Guess I needed to learn this anyway. thanks for your response
greyroots is offline   Reply With Quote
Unread 02-02-2011, 08:46 AM   #8
Not Yet Wild
Club Car
 
Join Date: Jul 2009
Location: South Carolina
Posts: 19
Default Re: 97 regen motor speed sensor

Just wanted to say I called FSIP and found out there was a diagram missing in the controller. After looking at the diagram its apparent that the regen relay must be by-passed. Gonna redo it tonight. Thanks folks, you got me thinking.
greyroots is offline   Reply With Quote
Unread 02-02-2011, 10:19 PM   #9
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: 97 regen motor speed sensor

Quote:
Originally Posted by greyroots View Post
Just wanted to say I called FSIP and found out there was a diagram missing in the controller. After looking at the diagram its apparent that the regen relay must be by-passed. Gonna redo it tonight. Thanks folks, you got me thinking.
Good detective work
GLEEMO is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
MCOR? Speed Sensor? Controller? Cart Runs at half speed. Advice, please. Electric Club Car
precedent motor speed sensor Electric Club Car
Club Car IQ, Blowing Speed Sensor? Electric Club Car
CC IQ speed sensor questions Electric Club Car
05 Western (ezgo) Speed Sensor Electric golf carts


All times are GMT -5. The time now is 05:20 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.