lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-03-2011, 03:20 PM   #1
Not Yet Wild
 
Join Date: Dec 2010
Posts: 31
Default Car still not working

I have a 94 Club Car 36v with a solid state controller. I replaced the batteries a couple of weeks ago and still nothing.

Am I missing something. I looked and the stickies and can't see that I've missed anything. Do the speed controllers go out?

Any one recommend a good place to take it to have it looked at in Sugar Land Tx.
Chuckd is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-03-2011, 04:24 PM   #2
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: Car still not working

Far as I know nearest dealer is in Houston?
Do you have or can get a digital volt meter? Harbor Freight have cheap when go bad throw away units for $3-$6. You need to check for each battery charge ( 6 volt fully charged 6.37 volts ) and pack battery voltage ( 36 volt pack should read 38.22 fully charged ). If you dont have proper power you wont get cart to run. When you replaced batterys ( hope not with auto or marine type batterys ) did you fully charge them before trying to use cart as there is a break in period needed before full power is available, BUT you are saying you have nothing? NO SOLENOID CLICKING, etc?
Get your self a meter and forum can walk you through tests to solve your problem. It can be just some thing simple as a cable installed wrong ( we have all done that ) so its worth a try???
OLD MEC is offline   Reply With Quote
Unread 02-03-2011, 04:39 PM   #3
Not Yet Wild
 
Join Date: Dec 2010
Posts: 31
Default Re: Car still not working

I do have a meter. I'll check it tonight after I get off work. I've also ran 4 charging cycles on it so far. Lights are really bright but that's it.
Chuckd is offline   Reply With Quote
Unread 02-03-2011, 05:34 PM   #4
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: Car still not working

Very Glad You Have a Meter as so much can be tested with it. Record your readings on each battery and then whole pack voltage and let us know what they are.
OLD MEC is offline   Reply With Quote
Unread 02-03-2011, 08:14 PM   #5
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Car still not working

OK so when did it quit , what happened to cause U to change batteries ???

DIGITAL Meter !!!!
GLEEMO is offline   Reply With Quote
Unread 02-04-2011, 12:00 AM   #6
Not Yet Wild
 
Join Date: Dec 2010
Posts: 31
Default Re: Car still not working

I needed to change the batteries every since I got the car from the previous owner. 2 were 2005 and the other 4 were 2008.

It was running and it just stopped. I started to push it back to the house and just before I got the my driveway I put it in reverse and hit the gas and it started going so I drive it up the driveway in reverse. When I stopped to move some things out of the way I got back in it and it wouldn't go again. It hasen't moved under it's own power since.
Chuckd is offline   Reply With Quote
Unread 02-04-2011, 11:59 AM   #7
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Car still not working

Quote:
Originally Posted by Chuckd View Post
I needed to change the batteries every since I got the car from the previous owner. 2 were 2005 and the other 4 were 2008.

It was running and it just stopped. I started to push it back to the house and just before I got the my driveway I put it in reverse and hit the gas and it started going so I drive it up the driveway in reverse. When I stopped to move some things out of the way I got back in it and it wouldn't go again. It hasen't moved under it's own power since.
Thanks , this info will help the experts on here determine U'r problem
GLEEMO is offline   Reply With Quote
Unread 02-04-2011, 12:58 PM   #8
Not Yet Wild
 
Join Date: Dec 2010
Posts: 31
Default Re: Car still not working

Once it warms up here a little I'm going to get out and check voltage on the batteries
Chuckd is offline   Reply With Quote
Unread 02-05-2011, 08:39 PM   #9
Not Yet Wild
 
Join Date: Dec 2010
Posts: 31
Default Re: Car still not working

Got out and checked the batteries today. All were in the 6.2 to 6.4 range. The entire pack was at 39. I'm thinking solenoid. Is this a golf cart specific part? And I took the cover off the v-thing. It was alittle dirty so I ran over it with some scotch brite.

I also noticed the wiper arm was not going all the way to the end with the gas on the floor so when I took it off to adjust it one of the ball sockets broke. So now I need more parts. How do I check the solenoid?
Chuckd is offline   Reply With Quote
Unread 02-06-2011, 10:51 AM   #10
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: Car still not working

While you had cover off V Glide did you check micro switch inside for proper contacting? To properly adjust V Glide travel allow .100 between stop and wiper arm when pedal is at rest. IF your solenoid does not click you need to confirm that you have power in this order
#1 Do you have power from key switch to micro on back of F&R control when key is on?
#2 Then do you have power going from micro on F&R ( when key is on and control in F OR R ) to micro inside V Glide unit?
#3 Do you have power from micro inside V Glide to solenoid small post when pedal is pressed? If all tests OK then the next item would be the solenoid itself. WARNING THIS CAN BE DANGEROUS There is a way to test solenoid but it requires you to jack up the back of cart on a solid flat surface and putting solid jack stands under rear axle on both sides so wheels cannot touch anything while test is being done and block the front wheels so no movement is possible. REMEMBER YOU HAVE ABOUT 1000 POUNDS OF WEIGHT WITH BATTERYS Then with a HD piece of wire, jumper across the 2 large posts on solenoid ( with key off, F&R in neutral, and pedal at rest ) then place F&R in run position and depress pedal and see if motor runs ( WARNING ONLY ALLOW MOTOR TO RUN FOR FEW SECONDS AS MOTOR CAN EXPLODE IF OVER SPEED IS ALLOWED ) I have seen motor parts fly up and through seat so be careful?
OLD MEC is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Charger Not Working Electric Yamaha
new light kit not working Electric EZGO
Way to verify whether OBC is working or not? Electric Club Car
Headlights aren't working Electric Club Car


All times are GMT -5. The time now is 04:22 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.