lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-15-2008, 02:29 PM   #1
Not Yet Wild
 
Join Date: Apr 2008
Posts: 2
Default Replaced OBC still nothing

I replaced the OBC on my 1995 club car, took charge but only moves an inch. I did notice there was an extra green wire coming from the new board, like on a regent model, my old board didn't have this wire, mines a series club car. Could this be the problem, or is ther somewhere I should connect this? Thanks for the help.
steverino is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-15-2008, 08:53 PM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Replaced OBC still nothing

if it has an extra wire than its not the right OBC could it be the problem? quite possible but i,m not 100% certain........i know though if it were the right one you wouldn,t have any extra wires............................................. .
shadowman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes



All times are GMT -5. The time now is 04:39 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.