lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-15-2011, 09:46 PM   #1
Not Yet Wild
Club Car
 
Join Date: Dec 2010
Location: Gainesville, FL
Posts: 72
Default New lift now metal rubbing sound

I just put on my new 6" Jakes Spindle lift on my 2006 CC precedent and now there is a sound coming from the passenger side rear tire, it sounds like metal rubbing. Any idea what that could be?

I also put on Rear HD Leafs and New Rear shocks and now there's that creaking sound that shocks make, is that an indication that I may have over tightened something? Or will it go away once the new wears off?
surf03 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-15-2011, 10:41 PM   #2
Gone Wild
 
gcs13's Avatar
Club Car
 
Join Date: Sep 2010
Location: North Ga.
Posts: 312
Default Re: New lift now metal rubbing sound

Have you checked your brakes and made sure they are not to tight?
gcs13 is offline   Reply With Quote
Unread 02-15-2011, 11:01 PM   #3
Not Yet Wild
Club Car
 
Join Date: Dec 2010
Location: Gainesville, FL
Posts: 72
Default Re: New lift now metal rubbing sound

That's what I was wondering. I know that they are tighter now but it didn't appear that they were too tight or in a bind.
surf03 is offline   Reply With Quote
Unread 02-16-2011, 03:01 PM   #4
Getting Wild
 
NewtoBuggies's Avatar
Club Car
 
Join Date: Jan 2011
Location: South Central Florida
Posts: 143
Default Re: New lift now metal rubbing sound

Does your wheel spin without a lot of drag or does it move a partial turn and stop?
NewtoBuggies is offline   Reply With Quote
Unread 02-16-2011, 04:59 PM   #5
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: New lift now metal rubbing sound

Real common for brakes to drag after lifts are installed. Check that you have enough play in linkage when brake cable pins are pulled at brake backing plate. Kits are available from sponsors to extend brake cablea.
OLD MEC is offline   Reply With Quote
Unread 02-16-2011, 05:59 PM   #6
Gone Wild
 
Texas001's Avatar
E-Z-GO
 
Join Date: Dec 2010
Location: Lone Star State
Posts: 315
Default Re: New lift now metal rubbing sound

Quote:
Originally Posted by surf03 View Post
I just put on my new 6" Jakes Spindle lift on my 2006 CC precedent and now there is a sound coming from the passenger side rear tire, it sounds like metal rubbing. Any idea what that could be?

I also put on Rear HD Leafs and New Rear shocks and now there's that creaking sound that shocks make, is that an indication that I may have over tightened something? Or will it go away once the new wears off?
I know I am mixing apples and oranges but on my EZGO I had to take the brake cables loose from a bracket on both sides to give the cable the slack it needed. You might check the cables to see it they are in a bind and activating your brakes.
Texas001 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Front tire rubbing Electric Club Car
Rubbing on 3" lift? Lifted Golf Carts
Rear end sway and rubbing Gas Club Car
99 club car tires rubbing Gas Club Car
New Wheels and tires rubbing Gas Yamaha


All times are GMT -5. The time now is 12:30 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.