lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-18-2011, 08:27 AM   #1
Doc
Gone Wild
 
Doc's Avatar
 
Join Date: Apr 2009
Posts: 227
Default Charger Isn't Charging

OK, here's where I'm at. Batteries were allowed to all go dead over this Winter (I know, I know), charged them all individually and then put the charger back on. I got the ubiquitous "click" from the charger when I plugged into the cart. I DID NOT, however plug it into the a/c outlet-totally forgot. It was like that all night and now the charger does nothing at all....no click, no hum nothing. What did I do? The batts all read 8.2-8.5 so I think they're OK. Is there a way to test the charger? IIRC, there was a way to bypass the relay in it, but I don't remember how. Anyone have anything on this? This is a 2000 48V Carryall.TIA
Doc
Doc is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-18-2011, 03:09 PM   #2
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: Charger Isn't Charging

Go to STICKIES SECTION and look for "Complte manual for Power Drive Charger" as it gives you needed info.
OLD MEC is offline   Reply With Quote
Unread 02-19-2011, 08:34 AM   #3
Doc
Gone Wild
 
Doc's Avatar
 
Join Date: Apr 2009
Posts: 227
Default Re: Charger Isn't Charging

Thanks, Old Mec....that is a HUGE resource! I'll get into the charger this weekend & post my results...thanks again~
Doc
Doc is offline   Reply With Quote
Unread 02-19-2011, 09:57 AM   #4
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Charger Isn't Charging

1. Make sure battery pack is above 36 Volts.
2. Unplug charger for 15 minutes.
3. Plug charger up make sure cart is in neutral
4. plug charger in , if the same (no charge) then try this http://www.buggiesgonewild.com/elect...er-system.html
GLEEMO is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
48V Charger not Charging Electric Club Car
Textron charger not charging Electric EZGO
Charging a 36v with a 12v charger? Electric Club Car
36 volt EZ GO charger keeps on charging Electric EZGO
Some charger/charging help please. Electric EZGO


All times are GMT -5. The time now is 05:30 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.