lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-19-2008, 09:56 PM   #1
Not Yet Wild
Club Car
 
Join Date: Apr 2008
Location: Muncie, Indiana
Posts: 5
Default Motor vibrates, no power on incline

Hello All, first time poster. Hope I don't screw up to bad. Here goes. I have a 2001 48V Club Car. Great cart, I have used it to move my 20' trailer(empty) around on my property(drive way). I've used it to move my Pontoon around too, no problems. Untill yesterday. I had just moved my pontoon back where it goes and the thing just acted like it had a cluch that was going out. It will not go up anykind of hill, and very little incline almost stops it in its tracks. It normally has more tork than the tires can handle. And the motor vibrates pretty bad now. The reason I've used it in such a manor is because of the room it takes to move them with a full sized cab and a half pickup truck. If anyone can tell me what I've broke, I would appreciate it. Thanks
PHIPHITTER is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-19-2008, 10:38 PM   #2
Just me. .
 
phasetim's Avatar
Club Car
 
Join Date: Sep 2007
Location: Pensacola, FL
Posts: 1,092
Default Re: Motor vibrates, no power on incline

May be as simple as just needing new batteries... Have the batteries ever been changed on it?
phasetim is offline   Reply With Quote
Unread 04-20-2008, 08:18 AM   #3
Not Yet Wild
Club Car
 
Join Date: Apr 2008
Location: Muncie, Indiana
Posts: 5
Default Re: Motor vibrates, no power on incline

Thanks for the input Phasetim. It has a yellow light on the dash that glows when the batteries are low, and it's not on. But I will put her on charge and hope for the best. I would just take it to the shop, but I've been laid off since November and don't want to spend money needlessly. Thanks again Phasetim. Have a good day today, and a better one tomorrow....
PHIPHITTER is offline   Reply With Quote
Unread 04-20-2008, 09:18 AM   #4
Just me. .
 
phasetim's Avatar
Club Car
 
Join Date: Sep 2007
Location: Pensacola, FL
Posts: 1,092
Default Re: Motor vibrates, no power on incline

If it's not the batteries its a problem that is similar. The shuttering is the motor not getting enough voltage to turn on the inclines. So you are either looking at motor issues (not likely, but possible), wiring (check for loose connections bad switches etc..etc.., controller problems (also not too likely, but possible), or batteries.
phasetim is offline   Reply With Quote
Unread 04-20-2008, 01:36 PM   #5
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Motor vibrates, no power on incline

how old are the batteries? i would check each batteries voltage and than the pack voltage, sure sounds like a battery issue.............dosn,t mean it is but sounds like one..............check cables give each one a tug make sure they are tight and all terminals clean, you can also test each battery cell with a hydrometer........................................ .....
shadowman is offline   Reply With Quote
Unread 04-20-2008, 01:43 PM   #6
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,913
Default Re: Motor vibrates, no power on incline

Does it make a grinding noise when it vibrates? Grinding noise = motor issue, stripped motor spline or stripped input shaft.
roady89 is offline   Reply With Quote
Unread 04-20-2008, 08:37 PM   #7
Not Yet Wild
Club Car
 
Join Date: Apr 2008
Location: Muncie, Indiana
Posts: 5
Default Re: Motor vibrates, no power on incline

Thank you Phasetim, Shadowman and roady89 for your input. I spent the whole day Sunday taking the batteries out and washing (with arm&hammer) and replaceing cable ends. Everything battery wise was in bad shape. I have never really taken good care of things like I should. Its actually my wifes golf cart and she has changed a few cables and its been fine. ( She's an Electrican), so I told her it was her job...... After reading up on battery maintanince I am going to check the water level every month. I read to check the water level after its fully charged. Didn't know that... I used about a gallon of distilled water to bring them up to the top of the grates. I put the thing on charge when I got done and it was really low. I think the idiot light that told me when to charge is bad, so I'm going to buy a meter for it. I'll let it charge over night and I'll post the outcome tomorrow. Thank you for your help... Have a good day today, and a better day tomorrow...
PHIPHITTER is offline   Reply With Quote
Unread 04-21-2008, 07:58 PM   #8
Not Yet Wild
Club Car
 
Join Date: Apr 2008
Location: Muncie, Indiana
Posts: 5
Default Re: Motor vibrates, no power on incline

Gentleman, I am happy to report I'm back in business. It's as strong as ever. I thank you for the help. I am a firm believer in Electric over Gas. This cart has Trojan batteries and they have weathered my abuse. They must be good batteries... E 0 May of 2000, almost 8 years old.
PHIPHITTER is offline   Reply With Quote
Unread 04-21-2008, 08:22 PM   #9
Gone Wild
 
Join Date: Jul 2007
Posts: 831
Default Re: Motor vibrates, no power on incline

Quote:
Originally Posted by PHIPHITTER View Post
Gentleman, I am happy to report I'm back in business. It's as strong as ever. I thank you for the help. I am a firm believer in Electric over Gas. This cart has Trojan batteries and they have weathered my abuse. They must be good batteries... E 0 May of 2000, almost 8 years old.
cool!!
gaston is offline   Reply With Quote
Unread 04-21-2008, 08:35 PM   #10
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,913
Default Re: Motor vibrates, no power on incline

Quote:
Originally Posted by PHIPHITTER View Post
Gentleman, I am happy to report I'm back in business. It's as strong as ever. I thank you for the help. I am a firm believer in Electric over Gas. This cart has Trojan batteries and they have weathered my abuse. They must be good batteries... E 0 May of 2000, almost 8 years old.
What was the cause of the trouble?
roady89 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
more power Gas Yamaha
no power Gas EZGO
No Power Electric Club Car
no power to motor Electric Yamaha
87 Marathon with new motor down on power Gas EZGO


All times are GMT -5. The time now is 06:19 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.