lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-05-2011, 08:13 PM   #11
Not Yet Wild
 
Join Date: Apr 2011
Posts: 9
Default Re: 01 CC slows going uphill-48v

The cart hasn't been run in 3 years. I think it was much faster before, but can only really tell you about now. My charger was broken so I waited until I got it fixed to use the cart except just unload and 1 trip around our small yard.
Charged fully, then road around block twice before next charge. Charged fully and tried again. On the 2% grade it got down so slow that a small dog was circleing the cart as we rode. We are not that heavy of people. Total load less than 400 lbs.

Putting back on charger. Road to next door neighbors and back. Total of 100 yds.
gdoss is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-05-2011, 08:20 PM   #12
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: 01 CC slows going uphill-48v

Is this a powerdrive charger ?
GLEEMO is offline   Reply With Quote
Unread 04-06-2011, 09:00 AM   #13
Not Yet Wild
 
Join Date: Apr 2011
Posts: 9
Default Re: 01 CC slows going uphill-48v

I had to go out of town. Will see what kind it is when I get back.
gdoss is offline   Reply With Quote
Unread 04-06-2011, 04:36 PM   #14
Not Yet Wild
 
Join Date: Apr 2011
Posts: 9
Default Re: 01 CC slows going uphill-48v

The batteries are made by Exide. They weigh 61 lbs each
gdoss is offline   Reply With Quote
Unread 04-06-2011, 06:15 PM   #15
Not Yet Wild
 
Join Date: Apr 2011
Posts: 9
Default Re: 01 CC slows going uphill-48v

Readings 8.37 to 8.40 total 50.21 after running 2.1 miles after full charge. Flat surface 13 mph. Uphill down to 6.0 at top pf 2-3% grade. Average mph 12.6 over entire run. Same course there and back 3 times. All done with GPS. What are these things suppose to run with a full charge? Checked each battery @ 8.53 before starting this experiment.
Total was 51.19 across all. I hear a whining noise that seems a bit loud coming from the motor. I know that is very vague, but trying to cover all bases. Thanks to everyone for your help
gdoss is offline   Reply With Quote
Unread 04-06-2011, 06:20 PM   #16
Not Yet Wild
 
Join Date: Apr 2011
Posts: 9
Default Re: 01 CC slows going uphill-48v

Charger is power Drive 2
gdoss is offline   Reply With Quote
Unread 04-06-2011, 09:03 PM   #17
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: 01 CC slows going uphill-48v

Always plug it up and leave it plugged in, after every ride,
if it has been several days or weeks since U rode it then,
unplug the charger wait 1 minute and plug it back up it will top off the batteries.

Your batteries should start going up slightly, after every complete charge
keep them clean and add only distilled water 1/4 to 1/2 over plates, keep cables tight and clean.
GLEEMO is offline   Reply With Quote
Unread 04-07-2011, 09:00 AM   #18
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: 01 CC slows going uphill-48v

On noise ( whine ) check 30 weight motor oil in differential. There are two plugs "location depends on brand of axle either from drivers or passenger side of housing", upper one is about even with axle shaft housing going to wheels ( fluid should be at bottom of hole, drain plug down near bottom. If fluid is low now would be good time to change with new 30 weight motor oil ( takes about 22 oz )
If this is not problem you may have bearing going out in motor, but test first to confirm sound location.
OLD MEC is offline   Reply With Quote
Unread 04-07-2011, 06:34 PM   #19
Not Yet Wild
 
Join Date: Apr 2011
Posts: 9
Default Re: 01 CC slows going uphill-48v

Thanks men. I'll keep my eye on things and let you know what happens. Maybe batteries will strengthen and I will check our rear end.
gdoss is offline   Reply With Quote
Unread 04-07-2011, 08:33 PM   #20
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: 01 CC slows going uphill-48v

I might be able to check out that rear-end (any pictures of her ,uuuuh I mean it)

Just kidding
GLEEMO is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
48v Par car starts OK then slows down Columbia ParCar
cart slows down Gas EZGO
86 ezgo slows down after take off Gas EZGO
96 Club Car Slows Electric Club Car
G1 speeds up, slows down Gas Yamaha


All times are GMT -5. The time now is 08:57 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.