lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-23-2011, 04:22 PM   #21
Not Yet Wild
 
razor3367's Avatar
Club Car
 
Join Date: Feb 2009
Location: Monroe, Louisiana
Posts: 28
Default Re: Cart not moving after upgrades!!

While I had the cart on jack stands I spun the wheels to see if brakes were dragging. The passenger side spins pretty easy but the drivers side is tough to spin 3/4 of a full revolution. The last 1/4 it breaks loose and spins real easy. I am going to look at the brake cables since I put a 7.5 " lift on it. But does the driver side sound likevit may be something else?
razor3367 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-23-2011, 05:36 PM   #22
Gone Wild
 
PLUMQUICK's Avatar
 
Join Date: Feb 2009
Posts: 487
Default Re: Cart not moving after upgrades!!

Quote:
Originally Posted by scottyb View Post
Put the cart up on jackstands so you don't get hurt.

Sounds like intermittent connection in the F&R? Sounds like you have switch up S1 and S2 also
When you hit the pedal and nothing happens..............keep the pedal depressed and slightly move the F&R handle to see if the contacts are making good contact, if you move the F&R handle and the cart runs..........then it's an issue with the new F&R. NOTE: DON'T push the pedal very far with the cart on jack stands.
PLUMQUICK is offline   Reply With Quote
Unread 04-25-2011, 03:46 PM   #23
Not Yet Wild
 
razor3367's Avatar
Club Car
 
Join Date: Feb 2009
Location: Monroe, Louisiana
Posts: 28
Default Re: Cart not moving after upgrades!!

Thanks to all that gave input. I wanted to update my status. I got the cart back together and it is running. I think I narrowed the problem to the key switch. Yesterday morning it was back to just the solenoid clicking when I hit the pedal. I was playing with the key switch while depressing the pedal and it would start running when I pushed the key harder to the run position side. The key I'm using is not an original club car key but one that someone robbed from maybe an ATv and it fit well enough to work. Does it make sense that this could cause the issue?

Ok it runs now but is hesitating as I slowly hit the pedal and it jumps and jerks all the way up to top speed then it runs smooth at full pedal. And wow this thing moves when it gets there!! 33 mph with 2 people in it. So what do you think is causing the hesitations and jerking up through the throttle range? I hooked a voltmeter up to the batteries during the rebuild (one of those small datel digital voltmeters mounted in the dash). And I watch the voltages as I accelerate and the voltage drops a lot during the hesitations sometimes as low as 46 volts and once up to speed it comes back up to 50 or above. Are my batteries just not able to handle the load and the hesitating is caused by that? Could it be the key switch not making good contact? Also notice the controller gets real hot after running awhile the wires dont get that hot but you can sure feel the controller what kind of temps can the controller handle? Any insights or advice??
razor3367 is offline   Reply With Quote
Unread 04-25-2011, 08:41 PM   #24
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Cart not moving after upgrades!!

If U know the key switch was/is an issue then go ahead and replace.
or jumper it for testing to determine if it is the switch "."
GLEEMO is offline   Reply With Quote
Unread 04-26-2011, 12:08 AM   #25
Not Yet Wild
 
razor3367's Avatar
Club Car
 
Join Date: Feb 2009
Location: Monroe, Louisiana
Posts: 28
Default Re: Cart not moving after upgrades!!

Thanks Gleemo, yes I think I will go ahead and replace the key switch and get a correct club car key. Just seems that the hesitating might be coming from someplace else since the cart never really stops accelerating really (I don't hear the solenoid clicking when the hesitations are happening)
razor3367 is offline   Reply With Quote
Unread 04-26-2011, 09:17 AM   #26
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: Cart not moving after upgrades!!

Bit of advice once you put a CC switch in ANYONE WITH A CC KEY CAN DRIVE YOUR CART? I use universal auto key switches ( at least most cart owners wont have a key for it ) with 3 positions ( NOT STARTING ) for controlling accessories as well as normal cart functions.
OLD MEC is offline   Reply With Quote
Unread 04-26-2011, 01:29 PM   #27
Not Yet Wild
 
razor3367's Avatar
Club Car
 
Join Date: Feb 2009
Location: Monroe, Louisiana
Posts: 28
Default Re: Cart not moving after upgrades!!

Thanks MEC, good advice!!
razor3367 is offline   Reply With Quote
Unread 04-26-2011, 08:14 PM   #28
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: Cart not moving after upgrades!!

Had major problems when first moved to Texas as if some one in park got tired they would just take your CC or Ezgo cart and park it in front of their home?? As a handicap person that cant walk over 30-50 ft I had to have some one run me through park until I found mine?
After that I changed switch so this would not happen anymore.
OLD MEC is offline   Reply With Quote
Unread 05-10-2011, 01:54 PM   #29
Not Yet Wild
 
razor3367's Avatar
Club Car
 
Join Date: Feb 2009
Location: Monroe, Louisiana
Posts: 28
Default Re: Cart not moving after upgrades!!

Just an update. I'm still fighting the hesitation issues when I hit the peddle. It shudders both in forward and reverse at less than WOT. I took the key switch out and hooked wires direct but that had no affect. Did not have this problem before upgrades. I'm thinking of the mcor but not sure. Any ideas on what to try next? Once I floor it it runs great. Thanks!!
razor3367 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Re: CART NOT MOVING AT ALL. Electric Club Car
Western Cart Not Moving Electric golf carts
slow moving cart Electric Club Car
slow moving cart Electric Club Car
Getting an Electric EZGO cart moving... Electric EZGO


All times are GMT -5. The time now is 09:56 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.