lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-30-2011, 09:25 PM   #1
Not Yet Wild
Club Car
 
Join Date: Feb 2009
Location: Madison,Georgia
Posts: 64
Default Charger pegs amp meter ?????

Need help,

Carryall onboard charger pegs the amp meter when it comes on. What might cause this. All connections checked and good. Any help appreciated.:help

Thanks in advance. Buddygo
BuddyGo is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-01-2011, 09:04 AM   #2
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: Charger pegs amp meter ?????

Very important have you checked batterys for condition and full charge? If its a factory charger or after market? If factory go to STICKIES under heading "Complete Manual For Power Drive Chargers" if after market I alway go to manufacturers site for help.
OLD MEC is offline   Reply With Quote
Unread 05-01-2011, 09:21 AM   #3
Not Yet Wild
Club Car
 
Join Date: Feb 2009
Location: Madison,Georgia
Posts: 64
Default Re: Charger pegs amp meter ?????

Batteries are close to full charge. It is original Powerdrive type charger. I have never seen it peg the amp gage even when the batteries were more discharged.
Anyone had this problem or similer.

Thanks, BG
BuddyGo is offline   Reply With Quote
Unread 05-01-2011, 11:20 AM   #4
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Charger pegs amp meter ?????

most cases when it pegs the meter its because of something in the batteries or cables.......have you tested and load tested the batteries? what kind of shape are the cables in? you could have a restriction somewhere..........
shadowman is offline   Reply With Quote
Unread 05-01-2011, 11:36 AM   #5
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Charger pegs amp meter ?????

does it drop after being connected for a while ?
GLEEMO is offline   Reply With Quote
Unread 05-01-2011, 12:32 PM   #6
Gone Wild
 
dougmcp's Avatar
 
Join Date: Mar 2009
Location: Roseville, CA
Posts: 2,757
Default Re: Charger pegs amp meter ?????

Sounds like you have a problem with 1 battery.
Plug the charger in let it charge for 20 minutes and then while it is still charging, take a voltage reading of each battery, the one with the highest charging voltage is usually the culprit.
dougmcp is offline   Reply With Quote
Unread 05-01-2011, 05:30 PM   #7
Not Yet Wild
Club Car
 
Join Date: Feb 2009
Location: Madison,Georgia
Posts: 64
Default Re: Charger pegs amp meter ?????

Thanks Guy's,

i will give try the above a try and report the results.

Best Regards, BG
BuddyGo is offline   Reply With Quote
Unread 05-04-2011, 08:52 PM   #8
Not Yet Wild
Club Car
 
Join Date: Feb 2009
Location: Madison,Georgia
Posts: 64
Default Re: Charger pegs amp meter ?????

Inspected all cables. They looked ok but I cleaned loosened and retightened all anyway. Must have had a bad connection on one or more, all is well now thanks to your advise. Charger acting normal

Best Regards, BG
BuddyGo is offline   Reply With Quote
Unread 05-04-2011, 08:58 PM   #9
Gone Wild
 
dougmcp's Avatar
 
Join Date: Mar 2009
Location: Roseville, CA
Posts: 2,757
Default Re: Charger pegs amp meter ?????

Probably a bad connection. Glad it's working now.
dougmcp is offline   Reply With Quote
Unread 05-04-2011, 09:15 PM   #10
just leave me alone
 
GLEEMO's Avatar
Club Car
 
Join Date: Aug 2008
Location: Tennessee
Posts: 5,643
Default Re: Charger pegs amp meter ?????

Quote:
Originally Posted by dougmcp View Post
Sounds like you have a problem with 1 battery.
Plug the charger in let it charge for 20 minutes and then while it is still charging, take a voltage reading of each battery, the one with the highest charging voltage is usually the culprit.
GLEEMO is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
State of charge meter.. bad meter? Electric EZGO
Amp meter Electric Yamaha
Soc meter Electric EZGO
Battery meter Electric Yamaha
Battery Meter Electric EZGO


All times are GMT -5. The time now is 11:48 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.