lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-12-2011, 08:49 AM   #11
Gone Wild
 
Fishing Dude's Avatar
Club Car
 
Join Date: Jul 2008
Location: Slums of Lake Erie
Posts: 3,722
Default Re: 99 elec club car not wanting to go - slow to nothing

Sounds like bad battery for sure. Had this trouble last summer waited till this year for new batts. How old are the batteries?
Fishing Dude is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-12-2011, 10:23 AM   #12
Not Yet Wild
 
stevesmitty79's Avatar
 
Join Date: Aug 2009
Location: Missouri
Posts: 36
Default Re: 99 elec club car not wanting to go - slow to nothing

I appreciate everyone's feedback thus far. I'm going to be busy today to attend to your suggestions, but I'm all over it the next few days.

Thanks and I'll update asap.
stevesmitty79 is offline   Reply With Quote
Unread 05-12-2011, 11:49 AM   #13
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 99 elec club car not wanting to go - slow to nothing

just wanted to eliminate the OBC if possible, just one thing to get out of the way..............
shadowman is offline   Reply With Quote
Unread 05-16-2011, 07:21 PM   #14
Not Yet Wild
 
stevesmitty79's Avatar
 
Join Date: Aug 2009
Location: Missouri
Posts: 36
Default Re: 99 elec club car not wanting to go - slow to nothing

Ok, a few days late, but this is what I got for scottyb's suggestion:

The cart has not been ridden since it won't go anywhere.

The no-load bank reading is 49.7 down from 51.7 several days ago. Pedal to the metal is 49.4.

The batts all read either 8.2 or 8.3 with a .1 drop under load.

The batts are 2003 but I can't find anything wrong with them. Then again, this whole process is a mystery to me.

Any thoughts?
stevesmitty79 is offline   Reply With Quote
Unread 05-16-2011, 07:25 PM   #15
Not Yet Wild
 
stevesmitty79's Avatar
 
Join Date: Aug 2009
Location: Missouri
Posts: 36
Default Re: 99 elec club car not wanting to go - slow to nothing

wilsontc81, you said to jump the yellow off the solenoid to the main negative battery post. I see the yellow as it connects to the controller. I see the neg off the bank as it connects on the next terminal on the controller. How should I jump those? Pull them off each terminal and jump them or just jump from terminal to terminal? Also, what is the test? Is it just loading on the pedal? Thanks.
stevesmitty79 is offline   Reply With Quote
Unread 05-16-2011, 08:25 PM   #16
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 99 elec club car not wanting to go - slow to nothing

i think what he means is get a jumper wire and go from the small post on soleniod where yellow wire is bolted over to the neg. terminal of #6 battery..............................
shadowman is offline   Reply With Quote
Unread 05-17-2011, 08:01 AM   #17
Not Yet Wild
 
Join Date: Feb 2011
Posts: 35
Default Re: 99 elec club car not wanting to go - slow to nothing

Quote:
Originally Posted by shadowman View Post
i think what he means is get a jumper wire and go from the small post on soleniod where yellow wire is bolted over to the neg. terminal of #6 battery..............................
Exactly, may not be tha problem, but it will eliminate the obc messing up.
wilsontc81 is offline   Reply With Quote
Unread 05-17-2011, 08:12 AM   #18
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 99 elec club car not wanting to go - slow to nothing

Quote:
Originally Posted by wilsontc81 View Post
Exactly, may not be tha problem, but it will eliminate the obc messing up.
yes it will unless the cart runs than its the OBC..........................
shadowman is offline   Reply With Quote
Unread 05-17-2011, 07:37 PM   #19
Not Yet Wild
 
stevesmitty79's Avatar
 
Join Date: Aug 2009
Location: Missouri
Posts: 36
Default Re: 99 elec club car not wanting to go - slow to nothing

I don't know if I did this right. I didn't unhook anything. I simply took one side of a pair of jumper cables, connected one to the solenoid with the large yellow cable and the other to the last negative terminal of the battery bank and it sparked/shorted. The key was off. I then took my tester and make the same connection and got full bank power, which has by now dropped from 51 a week ago to 48. Did I do it right?
stevesmitty79 is offline   Reply With Quote
Unread 05-17-2011, 09:11 PM   #20
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 99 elec club car not wanting to go - slow to nothing

it should have been the small post with the 18 gage yellow wire??......................
shadowman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
1988 Club Car (elec) Electric Club Car
need help 87 elec. club car Electric Club Car
Slow! How do I make my club car Gasser go really slow. Gas Club Car
98' 48v elec club car Golf Carts and Parts


All times are GMT -5. The time now is 03:05 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.