lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-24-2011, 01:22 PM   #1
Not Yet Wild
 
Join Date: May 2011
Posts: 12
Default Not getting a full charge

I have a 48 volt 2002 Club car in really good condition. It has new 6 batteries and a new Power drive 2 charger. All 6 batteries were checked with a load tester and a hydrometer. Good cables and connections. They are perfect. The charger was verified by plugging it into another cart and works perfectly started around 10 amps and went down to 0 over night. When I plug the charger into mine, the amps start around 7,8 and the charger shuts off after about 5 minutes. The charge light on the dash is putting out a code that comes on for 6 seconds and shuts off for 6 seconds. It does that twice then the light is on for about 54 seconds.

On 54 sec
Off 6 sec
On 6 sec
Off 6 sec
On 6 sec
Off 6 sec
On 54 sec
suppermansteve is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-24-2011, 06:26 PM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Not getting a full charge

welcome, i can,t tell you what the code is but for sure you have a issue with your cart............have you tried another charger on your cart and see if it acts the same? ........................................
shadowman is offline   Reply With Quote
Unread 05-24-2011, 11:43 PM   #3
Not Yet Wild
 
Join Date: May 2011
Posts: 12
Default Re: Not getting a full charge

No but I can. Remember I tested the charger on another cart and it works well.
suppermansteve is offline   Reply With Quote
Unread 05-25-2011, 08:58 AM   #4
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Not getting a full charge

yes but i want to see if another charger acts up on yours.................
shadowman is offline   Reply With Quote
Unread 05-25-2011, 11:05 AM   #5
Not Yet Wild
 
Join Date: May 2011
Posts: 12
Default Re: Not getting a full charge

So I put a good charger on it and it did the same thing. Charger came on for exactly 3 min at 10 amp then shut off so i think I can rule out the charger. If anyone suspects the On Board Computer can you give me details of why you think it might be the OBC. It seems some people like to automatically assume that's it, and give no description why. Thanks
suppermansteve is offline   Reply With Quote
Unread 05-25-2011, 11:42 AM   #6
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,093
Default Re: Not getting a full charge

Quote:
Originally Posted by suppermansteve View Post
So I put a good charger on it and it did the same thing. Charger came on for exactly 3 min at 10 amp then shut off so i think I can rule out the charger. If anyone suspects the On Board Computer can you give me details of why you think it might be the OBC. It seems some people like to automatically assume that's it, and give no description why. Thanks
The on board computer is the charger control. Your charger is little more than a transformer. The OBC tells it when to come on & off and how much amperage to put out...
scottyb is offline   Reply With Quote
Unread 05-25-2011, 11:51 AM   #7
Not Yet Wild
 
Join Date: May 2011
Posts: 12
Default Re: Not getting a full charge

The code that its putting out. Does anyone know what that is. The dash light is blinking.
On 6 sec
Off 6 sec
On 6 sec
Off 6 sec
On 33 sec
then repeats
suppermansteve is offline   Reply With Quote
Unread 05-25-2011, 02:30 PM   #8
Gone Wild
Club Car
 
Join Date: Apr 2011
Location: Texas
Posts: 600
Default Re: Not getting a full charge

from back side jump the center wire of the charge receptacle to ground
plug in charger what happens.





Let us know what happens and at what step it happens!!
gaminde is offline   Reply With Quote
Unread 05-25-2011, 02:41 PM   #9
Gone Wild
Club Car
 
Join Date: Apr 2011
Location: Texas
Posts: 600
Default Re: Not getting a full charge

Download the charger manual from the stickies for light info

The battery warning light will not illuminate if the charge is 90% or more complete. The onboard computer
will retain in memory the amount of charge needed to replenish the batteries and will complete
the charge during the next charge cycle.
When the charger DC cord is unplugged during a charge cycle, the battery warning light will illuminate
and remain illuminated for 10 seconds (25 seconds for Precedent vehicles) if the charge is less than
90% complete but the vehicle has enough power for 60 minutes of operation. This will alert the operator
that the vehicle may be used, but that it must be charged to completion as soon as possible.
The battery warning light will repeatedly illuminate for 10 seconds, at 4 second intervals (25 seconds,
at 10 second intervals for Precedent vehicles), if the charger times out at 16 hours and the batteries are
not sufficiently charged. This indicates an abnormal charge cycle. The charger and batteries should be
checked by your Club Car distributor/dealer.
The battery warning light will repeatedly illuminate for 10 seconds, at 4 second intervals (25 seconds,
at 10 second intervals for Precedent vehicles), during a charge cycle (with the DC plug still connected)
if AC power to the charger is interrupted. The light will go out when AC power is restored.
gaminde is offline   Reply With Quote
Unread 05-26-2011, 12:34 AM   #10
Not Yet Wild
 
Join Date: May 2011
Posts: 12
Default Re: Not getting a full charge

Again my charger works on my friends cart. The problem is in my club car somewhere. Not the charger. So why am I suppose to do a bypass on the charger with a jumper?
suppermansteve is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
99 CC 48 volt no go on full charge Electric Club Car
Still no torque, batteries full charge? Electric Club Car
EZGO charger cuts off before full charge Electric EZGO
club car batteries not taking full charge Electric Club Car
what's a full charge reading for a 48 volt 4 battery cart? Electric Club Car


All times are GMT -5. The time now is 05:56 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.