lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-06-2011, 09:52 AM   #1
Not Yet Wild
 
Join Date: Jun 2011
Posts: 5
Default Lost of speed and climbing ability

Suddenly my cart has lost approx half it's speed and crawls up grades. seems to charge okay and range is still good. I think someone may have installed the wrong motor at some point in the past. As far as I can tell it is a CC '02 IQ S/N AQ0221 - 150312. there is a 2nd S/N of NQ0299 - 150312 with code A 089: B 001: C 184. the motor is a GE cat # D390 model 5BC58JBS6381. the controller is a Curtis PMC model 1510-5201 48v 250 amp. The obc is from Lester Elect part3 21155-02. Any help in determing what caused the loss of power and speed would be appreciated.
2XBogey is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-06-2011, 09:59 AM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Lost of speed and climbing ability

welcome, is it a 2002? if your motor has a speed sensor and the cart has the M-cor for the speed system those would be 2 likely places to start.........there are some guys here who know much more about it but do you have the F&R lever or the rocker switch? and 1 or 2 soleniods?......how old are the batteries and have you checked them and your cable connections to make sure all are clean and tight?...................................
shadowman is offline   Reply With Quote
Unread 06-06-2011, 10:02 AM   #3
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: Lost of speed and climbing ability

Go to basics and test batterys for condition. If batterys are not up to full power you wont get the speed nor power you had before. If batterys test good then I would check motor speed sensor by having cart in ( RUN )and in ( forward ) and push by hand and see if cart slows down or is ( free rolling which means speed sensor or magnet is cracked or bad )
OLD MEC is offline   Reply With Quote
Unread 06-06-2011, 10:13 AM   #4
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,077
Default Re: Lost of speed and climbing ability

The D390 was an aftermarket high speed motor. It was designed to work with the stock controller but would respond better to a larger control. If the batteries and connections all check out I would suspect the brushes have worn if the motor has seen a few years of use.
scottyb is online now   Reply With Quote
Unread 06-06-2011, 10:13 AM   #5
Not Yet Wild
 
Join Date: Jun 2011
Posts: 5
Default Re: Lost of speed and climbing ability

Thanks for the prompt response. has rocker switch and "run"/"tow" toggle. batteries checked and connections clean. Not familiar with"M-cor" Before motor was changed, the cart would "brake" and charge meter go up when going down hill. since motor was changed, cart accerates coasting down hills.
2XBogey is offline   Reply With Quote
Unread 06-06-2011, 10:14 AM   #6
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,077
Default Re: Lost of speed and climbing ability

Thant is normal. Is the motor new?
scottyb is online now   Reply With Quote
Unread 06-06-2011, 10:19 AM   #7
Not Yet Wild
 
Join Date: Jun 2011
Posts: 5
Default Re: Lost of speed and climbing ability

The motor is now about 4 years old. Is it true that regen motors have connection posts with different diameters? This one has posts all the same diameter.
2XBogey is offline   Reply With Quote
Unread 06-06-2011, 10:21 AM   #8
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,077
Default Re: Lost of speed and climbing ability

There is no way you went 4 yrs with the wrong motor.
scottyb is online now   Reply With Quote
Unread 06-06-2011, 10:29 AM   #9
Not Yet Wild
 
Join Date: Jun 2011
Posts: 5
Default Re: Lost of speed and climbing ability

Where can I get info on checking/changing the brushes?
2XBogey is offline   Reply With Quote
Unread 06-06-2011, 11:31 AM   #10
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Lost of speed and climbing ability

you,ll have to pull the motor to check and or change brushes.......if you do be careful with the nuts they are double nutted you,ll have to hold the inner ones to break outer ones loose..............................
shadowman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Need More Hill Climbing Ability Gas EZGO
breaking ability Electric Club Car
ezgo speed lost Electric EZGO
Lost low speed on my 98 electric cart Electric Club Car
Climbing uphill Electric Club Car


All times are GMT -5. The time now is 01:06 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.