lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-07-2011, 06:32 PM   #1
Not Yet Wild
 
Join Date: May 2011
Posts: 18
Default Ladies and Gents...she actually runs!

I finally listened to everyone on here, took a step back, and started from scratch.

I pulled every component, wire, connector and device off the cart. I scrubbed everything with a fine tooth comb. Turns out, my forward/reverse had some loose internal components, and was crossing positive and negative leads. Small purchase later, and she runs like a champ.

Thanks for being patient with my stupid questions. I'm not much more qualified to help someone going through the same ordeal now, and feel better knowing I didn't give up and push the **** thing into the lake. Now I can move on to paint, lift kits, stereo systems...
Moocrew is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-07-2011, 06:39 PM   #2
Getting Wild
 
gabulldawg83's Avatar
Club Car
 
Join Date: May 2011
Location: Franklin GA
Posts: 121
Default Re: Ladies and Gents...she actually runs!

i just got mine running too. lucky for me it just needed batteries though. all my lifts, tires, motor, etc etc are all on order. im really excited about getting started. get some pictures up and keep 'em coming as you build.
gabulldawg83 is offline   Reply With Quote
Unread 06-07-2011, 06:41 PM   #3
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Ladies and Gents...she actually runs!

......................................... ....
shadowman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Runs 10 minutes then shuts off, wait 5 then runs again... Electric EZGO
runs good cold runs bad hot? Gas EZGO
Reverse...runs awesome Forward..runs bad Gas EZGO
Finished my Club Car Villager project (for my ladies) Electric Club Car
Finished my Club Car Villager project (for my ladies) Electric Club Car


All times are GMT -5. The time now is 02:12 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.