lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-13-2011, 01:30 PM   #1
Not Yet Wild
 
Join Date: Jun 2011
Posts: 12
Default 96 CC no power

I have a 96 Club Car 48V on jack stands run smooth and fast, put the wheels on the ground and nothing trys but can't or won't go batteries are good and full charged.What to do?
mikie1953 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-13-2011, 04:07 PM   #2
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: 96 CC no power

Always start with basics and confirm by at least digital voltage testing each battery ( 8 volt batterys fully charged 8.49 just to be sure it has 4 distilled water fills ) and then total pack voltage ( 50.96 volts ) just putting charger on does not mean that its fully charged. How was batterys condition of arrived at, load testing, hydrometer testing ( 1.275 ) or ??
Is your cart a series ( F&R lever under right leg ) or Shunt Regen 1 ( F&R rocker type switch under right leg ).
Its obvious that some thing is not feeding enough power to motor or the motor it not over come drag to move cart when on ground.
Its a proccess of eliminating from power supply ( batterys ) to wheels on ground.
OLD MEC is offline   Reply With Quote
Unread 06-13-2011, 04:46 PM   #3
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 96 CC no power

load test the batteries and make sure cables are clean and tight.......you might have a battery dropping out under load.....when you say batteries are good what do you mean? have you tested them what is pack voltage.......................
shadowman is offline   Reply With Quote
Unread 06-14-2011, 08:42 AM   #4
Not Yet Wild
 
Join Date: Jun 2011
Posts: 12
Default Re: 96 CC no power

It has F&R lever under right leg did load and digital test all good done have a hydro tester (guess I need one) would the speed control attched to the pedal have anything to do with it. I have all the spare parts to change everything obc, etc , But I just don't know to go from here.

Tested the Batteries changed the motor and trans removed and cleaned all cables replaced forward micro switch witch is what got it moving when on jack stands (it didn't do that before). cleaned F&R switch even cleaned brake drums & shoes.NOW WHAT, THANKS FOR ALL YOUR HELP.
mikie1953 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Power Wise Charger worked after board replaced now back to no power Electric EZGO
have power on ezgo buggy no power light Electric EZGO
Power lag after 295/350 mod.. Gas EZGO
Power in Reverse/Little Power in Forward Gas Harley Davidson
No Power Help!!!!!!!!! Electric EZGO


All times are GMT -5. The time now is 04:21 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.