lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-14-2008, 09:35 PM   #1
Not Yet Wild
 
Join Date: May 2008
Posts: 7
Default REGEN 2 Controller

I finally found a wiring diagram online, found my problem being a corroded microswitch in the v-glide (I know I should have started there). However now I have +48 Volts to all four lugs on my motor (f1, a1, f2, a2). When I switch from tow to run I can hear the Dynamic Braking solenoid kick in, which I think is probably normal. I did a low voltage test on the motor and it passed. Do I have a solenoid problem or a controller problem and is there any more steps I can take to troubleshoot it???
crazcoyote is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
testing a controller for 48v regen II Electric Club Car
97 regen wont go Electric Club Car
Regen 2 computer Electric Club Car
regen vs std Electric Club Car
lifted 97 regen Electric Club Car


All times are GMT -5. The time now is 03:12 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.