lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-16-2008, 12:07 PM   #1
Not Yet Wild
 
Join Date: May 2008
Posts: 2
Default Electric Cart Started felt like belt slipping

I am new to this, so please be patient with me. I have recently purchased a new (used ) golf cart, and on my second round of use the cart started to shimmy, felt like it had a belt that was slipping. It would shimmy for a little then go smoothly, until the 6th hole where it would not go at all. The batteries are about a year old, and very little use over the last year. If you have any ideas, I would appreciate your input, as to where to start to look for the problem.
bbhuey is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-16-2008, 12:12 PM   #2
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,912
Default Re: Electric Cart Started felt like belt slipping

Check all your connections and make sure they are clean and tight. I mean ALL of them. Take them off one at a time, clean them and re-connect. Check your water level in your batteries while you are checking the cables.

Check out this thread. Electric Cart Owners Read This Before Posting
roady89 is offline   Reply With Quote
Unread 05-16-2008, 03:16 PM   #3
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Electric Cart Started felt like belt slipping

yee it sounds like you have either a battery or cable problem so do as advised....what brand batteries? just because they are only a year old dosn,t mean they couldn,t be bad or just one of them bad and thats all it takes is one.................................
shadowman is offline   Reply With Quote
Unread 05-16-2008, 04:48 PM   #4
Not Yet Wild
 
Join Date: May 2008
Posts: 2
Default Re: Electric Cart Started felt like belt slipping

Thank you for the fast reply. I will check the cables.
bbhuey is offline   Reply With Quote
Unread 05-16-2008, 11:27 PM   #5
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: Electric Cart Started felt like belt slipping

Welcome bbhuey....................
rusty is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Electric Club Car 1996 drive slipping on accel Electric Club Car
Yamaha belt slipping Gas Yamaha
Steering Wheel Slipping Electric Club Car
EZ Go Electric Cart Identification Electric EZGO
Help me understand my Electric cart.....Please? Extreme DC!


All times are GMT -5. The time now is 06:32 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.