lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-21-2011, 10:06 PM   #1
Not Yet Wild
 
Join Date: Aug 2008
Posts: 8
Default cart will not go...no life

I just replaced the batteries in my 48 volt and cart ran fine for the entire day.Used a "donated" charger and blew a fuse in the yellow fuse holder.A friend replaced blown fuse with another(was not a fuse for a 48 volt golf cart but was from/for some type of appliance??),hooked "donated" charger back up and nothing(fuse did not blow).Went to drive the cart around to the garage and nothing in fwd or rev.I hear the click when pressing the pedal but that's it.What have I done to my cart??Has something blown/burnt out further down the line?
dad'lfixit is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-21-2011, 10:45 PM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: cart will not go...no life

welcome to BGW, its possible ...........what year and model...............
shadowman is offline   Reply With Quote
Unread 06-21-2011, 11:12 PM   #3
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,069
Default Re: cart will not go...no life

Some of those carts had a second in line fuse at the solenoid... they are 3/8ths amp fuse. Be careful what you replace them with.
scottyb is offline   Reply With Quote
Unread 06-22-2011, 07:58 AM   #4
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: cart will not go...no life

good point scotty some do have 2 and you have to use the same fuse.....................
shadowman is offline   Reply With Quote
Unread 06-22-2011, 08:00 AM   #5
Not Yet Wild
 
Join Date: Aug 2008
Posts: 8
Default Re: cart will not go...no life

Thanks for the replies...sorry it took so long to get back w/you...I believe the year is '97-'98? The sticker under the steering wheel reads:serial #:AQ0214-134040.Hope this helps.The first fuse that was found blown was 3/8 amp...the fuse that was installed was,I'm sure,much larger amperage (3 amp?)which is why I think it didn't blow and something further down the line did.Is it possible that the ecm needs to be reset or would that have fried since it was the next componant in line?
dad'lfixit is offline   Reply With Quote
Unread 06-22-2011, 08:03 AM   #6
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: cart will not go...no life

you have a 2002 cart............................
shadowman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
87 CC Gasser - New Life to an Old Cart Gas Club Car
Started life as a golf cart Lifted Golf Carts
Started life as a Golf Cart Golf Cart Racing


All times are GMT -5. The time now is 05:05 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.