lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-29-2011, 09:47 PM   #1
Not Yet Wild
Club Car
 
Join Date: Oct 2009
Location: Rock Hill, SC
Posts: 4
Default New Trojan Batteries, Cart Won't Charge

Guys,

So, I put my new Trojan 875's in my ClubCar this morning. I have a 2001 ClubCar DS Series 48V cart.

Well, I wired everything back up and plugged it in........nothing. I thought that maybe the batteries were already charged so I didn't really think about it.

Got home this afternoon and decided to take it for a spin. Rode about 15-20 minutes and parked it. Plugged in again.........nothing.

I am now worried. I have checked the fuse in the yellow holder and nothing.

Anything else I can check?
sayleboat is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-29-2011, 09:50 PM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: New Trojan Batteries, Cart Won't Charge

are you certain you hooked everything back up right? go over everything you did, was everything ok before you changed batteries?......................
shadowman is offline   Reply With Quote
Unread 06-29-2011, 09:58 PM   #3
Not Yet Wild
Club Car
 
Join Date: Oct 2009
Location: Rock Hill, SC
Posts: 4
Default Re: New Trojan Batteries, Cart Won't Charge

Shadow,

Everything was fine before changing batteries.....no issues whatsoever.

I am going to look again tomorrow. I have checked the wiring diagram several times versus what I wired, and that is right.

But, I have been staring at that thing for so long that I may be overlooking something.
sayleboat is offline   Reply With Quote
Unread 06-29-2011, 09:59 PM   #4
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: New Trojan Batteries, Cart Won't Charge

it only takes one wire and it happens all the time......more than you would think.....and since it was fine before hand??? know what i mean.....just take your time................................
shadowman is offline   Reply With Quote
Unread 06-29-2011, 10:02 PM   #5
Not Yet Wild
Club Car
 
Join Date: Oct 2009
Location: Rock Hill, SC
Posts: 4
Default Re: New Trojan Batteries, Cart Won't Charge

Other than the red positive coming from one side, and the black negative coming from the other side, what should I look for?
sayleboat is offline   Reply With Quote
Unread 06-29-2011, 10:09 PM   #6
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,093
Default Re: New Trojan Batteries, Cart Won't Charge

If you have a multimeter you can check voltage at the charge receptacle and see what the charger sees?

Also look under the cart and all around to see if there is a disconnected wire somewheres?
scottyb is offline   Reply With Quote
Unread 06-29-2011, 10:56 PM   #7
Getting Wild
 
TheAspec's Avatar
E-Z-GO
 
Join Date: May 2011
Location: Georgia
Posts: 110
Default Re: New Trojan Batteries, Cart Won't Charge

Make sure you have the 10 gauge red wire to the carts charge receptical connected to battery #1.
TheAspec is offline   Reply With Quote
Unread 06-30-2011, 07:57 AM   #8
Not Yet Wild
Club Car
 
Join Date: Oct 2009
Location: Rock Hill, SC
Posts: 4
Default Re: New Trojan Batteries, Cart Won't Charge

Okay guys.........I am an idiot. Looked this morning for about 30 seconds and realized that I failed to wire the 10 gauge wire back to battery 1.

Hooked it up and works like a charm.

Thanks for the help. Probably would not have found that problem without the recommendation.
sayleboat is offline   Reply With Quote
Unread 06-30-2011, 08:05 AM   #9
Gone Wild
 
Fishing Dude's Avatar
Club Car
 
Join Date: Jul 2008
Location: Slums of Lake Erie
Posts: 3,722
Default Re: New Trojan Batteries, Cart Won't Charge

No YOUR NOT AN IDIOT, an idiot would not have found it yet alone admit to it.
Fishing Dude is offline   Reply With Quote
Unread 06-30-2011, 08:27 AM   #10
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: New Trojan Batteries, Cart Won't Charge

Quote:
Originally Posted by sayleboat View Post
Okay guys.........I am an idiot. Looked this morning for about 30 seconds and realized that I failed to wire the 10 gauge wire back to battery 1.

Hooked it up and works like a charm.

Thanks for the help. Probably would not have found that problem without the recommendation.
.......figured it was something you just forgot.........happens all the time.............................
shadowman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Batteries test fine, cart will not charge Electric EZGO
Trojan batteries Electric Club Car
Trojan Batteries Electric Club Car
club cart batteries won't charge better than 6.5 out of 15 Electric Club Car
Alternator On Cart To Charge Batteries Electric EZGO


All times are GMT -5. The time now is 07:46 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.