lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-02-2011, 03:06 PM   #1
Not Yet Wild
Club Car
 
Join Date: Jul 2011
Location: Vallejo, CA.
Posts: 13
Default Charger does not start when plugged in

I have a 1996, 48v. clubcar. I had not used it in over a year because it needed new batteries which i recently purchased and my friend installed for me. They charged up great, I played a round of golf, plugged the charger in and the charger did not come on.
I know the problem lies in my cart and not the charger because I tried another charger I know was in working order and still nothing.

I am very much not mechanically inclined, so any advise possibly in simple terms (if there is such a thing), and if not, I do have some guy friends that hopefully can help.

Thank-You for your time
Sharon
bongokittykat is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-02-2011, 03:42 PM   #2
Gone Wild
 
Fishing Dude's Avatar
Club Car
 
Join Date: Jul 2008
Location: Slums of Lake Erie
Posts: 3,722
Default Re: Charger does not start when plugged in

Check your pack voltage, then check your voltage at the plug.
Fishing Dude is offline   Reply With Quote
Unread 07-02-2011, 04:05 PM   #3
Not Yet Wild
Club Car
 
Join Date: Jul 2011
Location: Vallejo, CA.
Posts: 13
Default Re: Charger does not start when plugged in

I will get a friend to check voltage for me. maybe you can answer a question... What is my obc? Is that "on board computer"?
bongokittykat is offline   Reply With Quote
Unread 07-02-2011, 04:09 PM   #4
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Charger does not start when plugged in

yes it is....your 96 is the dash battery light red or orange? if red thats the original OBC which had lots of issues....at this point i,m not gonna say thats your problem but i,d be willing to bet........your F&R selector is it the lever style or the small rocker switch?..............................
shadowman is offline   Reply With Quote
Unread 07-03-2011, 07:06 PM   #5
Not Yet Wild
Club Car
 
Join Date: Jul 2011
Location: Vallejo, CA.
Posts: 13
Default Re: Charger does not start when plugged in

My battery light is orange and my F&R is lever style
bongokittykat is offline   Reply With Quote
Unread 07-03-2011, 08:56 PM   #6
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Charger does not start when plugged in

ok well the OBC may have replaced once already than.....your cart should have a red light but they gave out an upgrade kit with a OBC for that year which included an orange light to swap with the red one........is the receptical fuse good? the cart still runs right? just won,t charge?...........................
shadowman is offline   Reply With Quote
Unread 07-04-2011, 08:33 PM   #7
Not Yet Wild
Club Car
 
Join Date: Jul 2011
Location: Vallejo, CA.
Posts: 13
Default Re: Charger does not start when plugged in

We took the fuse with us and are going to replace it. Tomorow I will try plugging it in and see if it still drives. I am in a cart barn at a golf course but I think we can still finaggle some room to maneuver, so I will give you an update tomorrow. And, again, thank you for your help!
bongokittykat is offline   Reply With Quote
Unread 07-04-2011, 09:00 PM   #8
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,069
Default Re: Charger does not start when plugged in

Borrow a floor jack and get one rear wheel off the ground for testing purposes? Then let her charge.
scottyb is offline   Reply With Quote
Unread 07-05-2011, 10:55 PM   #9
Not Yet Wild
Club Car
 
Join Date: Jul 2011
Location: Vallejo, CA.
Posts: 13
Default Re: Charger does not start when plugged in

Could not find a replacement fuse (not at automotive shop anyway) although the fuse does not appear to be blown so put fuse back in, plugged charger in and put in gear and the cart DID NOT go so I guess that is a good thing as it is not my obc................
...............unfortunantly, I don't know where to go from here....
bongokittykat is offline   Reply With Quote
Unread 07-05-2011, 11:43 PM   #10
Not Yet Wild
Club Car
 
Join Date: Jul 2011
Location: Vallejo, CA.
Posts: 13
Default Re: Charger does not start when plugged in

bongokittykat is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
fuse blows when charger is plugged in??? Electric Club Car
Plugged in charger after rebuild, hot plastic smell Electric Club Car
94 Metalist sparks when charger is plugged in Electric EZGO
charger will not kick on when plugged in Electric EZGO
Charger will not engage when plugged into cart Electric EZGO


All times are GMT -5. The time now is 05:06 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.