lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-04-2011, 02:18 PM   #1
Not Yet Wild
Club Car
 
Join Date: Jul 2011
Posts: 4
Default powerdrive 2 issues and speed issues.

I have a 2003 club car 48 v. New batteries. 8.1 -8.2 across all and 48.5/49.5 on pack. It developed and issue where it would drop to half speed intermittently. Around the same time the charger was fine but then started tripping the breaker. I changed the breaker and other servicable parts in the charger. Now the charger clicks on as normal but pins the amp meter all the way to the right, above the 15 amp mark. It slowly comes down but never below 12 amps. The pack is charging up but I will not leave the charger on for more than a few hours because of this. The cart is now running half speed all the time and will run all day like this. Reverse is full speed. I am new to this forum and have read on speed sensors. I did turn on the key, put in F and push. The cart rolls free, no braking so I think the speed sensor is bad. Not sure if this has any relation to the charger issue. Any thoughts would be appreciated.
ChiefColdBeer is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-04-2011, 02:24 PM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: powerdrive 2 issues and speed issues.

welcome to BGW.......with those readings i would load test the batteries and check the cells for SG see what readings you get.......its possible to get a bad battery thats dragging everything down.....did the speed issue start after battery replacement? cables all clean and tight? your F&R is it the lever or rocker switch.......................................
shadowman is offline   Reply With Quote
Unread 07-04-2011, 02:54 PM   #3
Not Yet Wild
Club Car
 
Join Date: Jul 2011
Posts: 4
Default Re: powerdrive 2 issues and speed issues.

yes and no on the speed after replacing batteries. The old batteries ran for a short period, about 1/2 miles flat out then fall off. it would hit half speed and crawl home. The speed issue now is pretty constant so not sure if its the batts or a progression of an issue. Replaced all new cables with the batts. Clean and tight. The F/R switch is the rocker located on the wall in front of the Batts. Checked the remaining connections and everything is clean and tight. This is an industrial model club car two seater. Thanks
ChiefColdBeer is offline   Reply With Quote
Unread 07-04-2011, 04:11 PM   #4
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: powerdrive 2 issues and speed issues.

do you have the big single resistor coil behind the battery pack? if so drive it for a few hundred feet and than get off lft the seat and see if the coil is glowing red.........................................
shadowman is offline   Reply With Quote
Unread 07-04-2011, 05:04 PM   #5
Not Yet Wild
Club Car
 
Join Date: Jul 2011
Posts: 4
Default Re: powerdrive 2 issues and speed issues.

No to a single big resistor coil. I do have a aluminum box about 4 by 6 inches with wires running into it behind the batteries. I just tested the batts again and have 8.2 to 8.1 on all 6 batteries but the pack only shows 40.8 volts. I cant understand this one. The batts are hooked up correctly. Any ideas?
ChiefColdBeer is offline   Reply With Quote
Unread 07-04-2011, 06:08 PM   #6
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: powerdrive 2 issues and speed issues.

that should be your controller the box that is..............where are you testing pack voltage at? yeah if your getting 8.1 and 8.2 pack should be more than 40.......are these new batteries? how many water fill holes 3 or 4 ...........................
shadowman is offline   Reply With Quote
Unread 07-05-2011, 09:30 AM   #7
Not Yet Wild
Club Car
 
Join Date: Jul 2011
Posts: 4
Default Re: powerdrive 2 issues and speed issues.

These are all 4 hole, 8 volt batts. Water is full on all. I checked the pack across the pack itself at the batt terminals. SG is good on all. It looks like I am missing a batt in the pack but they all have proper voltage individually. termianls are all good as are the cables. Just dont understand the drop to 40.8 volts. Makes no sense to my simple mind.
ChiefColdBeer is offline   Reply With Quote
Unread 07-05-2011, 10:27 AM   #8
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: powerdrive 2 issues and speed issues.

it makes no sense at all more so because you are checking right at the batteries.......ok wher are the 2 batteries you are testing for pack voltage? your #1 battery should be the rear battery on pass side and #6 should be rear battery on drivers side.......i,m guessing your checking at these 2 batteries right?.......................................
shadowman is offline   Reply With Quote
Reply

Tags
chargers, club car, half speed
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Speed issues with 94 club car electric Electric Club Car
Power and or speed issues !994 EZGO 36v Electric EZGO
97 Powerdrive+ issues Electric Club Car
Club Car gas speed issues Gas Club Car
Speed Issues with Electric Club Car Electric Club Car


All times are GMT -5. The time now is 06:10 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.