lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-04-2011, 04:41 PM   #1
Not Yet Wild
 
Join Date: Jul 2011
Posts: 10
Default Sorry it is a 1997 that I power washed and now is slow

I power washed my 1997 48v CC and now it is ver slow. I cleaned all the connectors on the pie switch and the f-r switch then put back together. I made the pie switch adjust all the wway to the top and that helped but it still is not up to full snuff. Right after I washed it it was buzzing for a bit them quit. I am not a good electrical guy so any help would be greatly appreciated.
Toolie663 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-04-2011, 04:47 PM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Sorry it is a 1997 that I power washed and now is slow

it could also be you got the controller wet and it needs to dry..........................
shadowman is offline   Reply With Quote
Unread 07-04-2011, 04:48 PM   #3
Not Yet Wild
 
Join Date: Jul 2011
Posts: 10
Default Re: Sorry it is a 1997 that I power washed and now is slow

Is the controller the box under the back deck panel area?
Toolie663 is offline   Reply With Quote
Unread 07-04-2011, 04:52 PM   #4
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Sorry it is a 1997 that I power washed and now is slow

yep.....................................
shadowman is offline   Reply With Quote
Unread 07-04-2011, 07:01 PM   #5
Gone Wild
 
sonicj's Avatar
Club Car
 
Join Date: Oct 2010
Location: Panama City, FL
Posts: 1,408
Default Re: Sorry it is a 1997 that I power washed and now is slow

what did you clean your "pie" with? denatured alcohol or 99% isopropyl is safe for de-engerized electronics and will expedite the evaporation of any remaining moisture. a air compressor &/or hair dryer helps too.
-sj
sonicj is offline   Reply With Quote
Unread 07-04-2011, 09:29 PM   #6
Not Yet Wild
 
Join Date: Jul 2011
Posts: 10
Default Re: Sorry it is a 1997 that I power washed and now is slow

I cleaned them with a wire brush on contacts. I have set it out in the sun for two days so I would think it should be dry by now but not sure. I have ran it around town a bit and it keeps going just not as much power as it should have.
Toolie663 is offline   Reply With Quote
Unread 07-04-2011, 10:38 PM   #7
Gone Wild
 
sonicj's Avatar
Club Car
 
Join Date: Oct 2010
Location: Panama City, FL
Posts: 1,408
Default Re: Sorry it is a 1997 that I power washed and now is slow

hmm.... could a bristle from the wire brush be lodged between the last two contacts?
sonicj is offline   Reply With Quote
Unread 07-04-2011, 11:16 PM   #8
Gone Wild
 
rabbitreborn's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Central Florida
Posts: 2,704
Default Re: Sorry it is a 1997 that I power washed and now is slow

on the controller, pull the wires off the #2 and #3 spade. using a DVOM set for Ohms, get a reading on those 2 wires with the pedal up and then again with the pedal to the floor..... Post your results please.
rabbitreborn is offline   Reply With Quote
Unread 07-04-2011, 11:31 PM   #9
Not Yet Wild
 
Join Date: Jul 2011
Posts: 10
Default Re: Sorry it is a 1997 that I power washed and now is slow

Where is the spade
Toolie663 is offline   Reply With Quote
Unread 07-04-2011, 11:34 PM   #10
Gone Wild
 
rabbitreborn's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Central Florida
Posts: 2,704
Default Re: Sorry it is a 1997 that I power washed and now is slow

sorry, spade connectors... small flat pieces of metal that the wire connector slips onto.... there should be 3 of them in a row on the box.
rabbitreborn is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Lack of power club car 1997 (gas) Gas Club Car
Power washed 1996 CC and now slow going Electric Club Car
1997 cc 48v low power Electric Club Car
1997 Club Car Slow moving Electric Club Car
1997 E-Z-NOT SO SLOW TXT Videos


All times are GMT -5. The time now is 09:28 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.