lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-16-2011, 01:52 PM   #1
Not Yet Wild
 
Join Date: Jul 2011
Posts: 3
Default 1988 Club Car jumps when pressing accelerator pedel

Hello and thanks in advance for any help!!

I have a 1988 Club Car that jumps when first starting off. I was living with it until the other day when it got "stuck" open. As I hit the accelerator pedel the car took off and even when hitting the brake the motor kept going (no foot on Accelerator Pedel). Finally stopped when I hit a fence (only traveled about 10 feet) and with my foot on the brake pedel the wheels were still spinning.

I have jacked the rear wheels and slowly pushed the accelerator pedel forward. I get 5 clicks from the micro switches. Then when I put the car on forward I get one click and then on the 2nd through 4th the motor speeds up at each click. From what I have been reading, this sounds just like it is supposed to be working. So I am now lost...

Is it possible the second solenoid be going bad and just acts up intermittenly? Do you recomend any other testing? Or could there be a problem with the micro switches? Maybe that is where the problem is at?

Thanks again for any help.
ShutterFox is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-16-2011, 03:36 PM   #2
Not Yet Wild
 
Join Date: Jul 2011
Posts: 3
Default Re: 1988 Club Car jumps when pressing accelerator pedel

I wanted to post an update... I put a voltmeter across each solenoid and each got voltage in turn. So each works and I guess that also means that the micro switches are working to. So what is causing the jumping and sticking of the gas???
ShutterFox is offline   Reply With Quote
Unread 07-16-2011, 03:39 PM   #3
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,042
Default Re: 1988 Club Car jumps when pressing accelerator pedel

Yes, solenoids often fail intermittently before they fail completely... Just because they make a clicking noise does not mean they work either, but in your case sounds like they are working some time... My advise is to replace them all.
They are all 23 yrs old..... have all clicked a million times and are all going to start filing about now... one today ~ one more in a month or soon after.... and so on.
scottyb is offline   Reply With Quote
Unread 07-16-2011, 03:47 PM   #4
Gone Wild
 
Join Date: Jun 2011
Location: Houston
Posts: 235
Default Re: 1988 Club Car jumps when pressing accelerator pedel

Quote:
Originally Posted by ShutterFox View Post
Hello and thanks in advance for any help!!

I have a 1988 Club Car that jumps when first starting off. I was living with it until the other day when it got "stuck" open. As I hit the accelerator pedel the car took off and even when hitting the brake the motor kept going (no foot on Accelerator Pedel). Finally stopped when I hit a fence (only traveled about 10 feet) and with my foot on the brake pedel the wheels were still spinning.

I have jacked the rear wheels and slowly pushed the accelerator pedel forward. I get 5 clicks from the micro switches. Then when I put the car on forward I get one click and then on the 2nd through 4th the motor speeds up at each click. From what I have been reading, this sounds just like it is supposed to be working. So I am now lost...

Is it possible the second solenoid be going bad and just acts up intermittenly? Do you recomend any other testing? Or could there be a problem with the micro switches? Maybe that is where the problem is at?

Thanks again for any help.
I recommend a crash helmet
noserider is offline   Reply With Quote
Unread 07-16-2011, 04:06 PM   #5
Not Yet Wild
 
Join Date: Jul 2011
Posts: 3
Default Re: 1988 Club Car jumps when pressing accelerator pedel

You know, I didn't really think about the fact that they are 23 years old!! I will replace them... Also, the microswitches... Do you think they are OK? Or do I need replace them too?
ShutterFox is offline   Reply With Quote
Unread 07-16-2011, 05:32 PM   #6
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,042
Default Re: 1988 Club Car jumps when pressing accelerator pedel

Quote:
Originally Posted by ShutterFox View Post
You know, I didn't really think about the fact that they are 23 years old!! I will replace them... Also, the microswitches... Do you think they are OK? Or do I need replace them too?

They have clicked as many times.... I used to see a complete refurb kit on ebay 5 micros, the slider, & 5 solenoids.

If it's not there let me know and I'll put a kit together 4 U
scottyb is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2002 g16 yamaha (gas) very high pitch squeal on pressing accelerator Gas Yamaha
87 Club Car Accelerator Linkage Rod Gas Club Car
Cart moves forward without pressing the accelerator Electric Club Car
96-97 club car moves when the key is off or on with out pressing the accelerator Electric Club Car
48v CC runs without pressing accelerator,key on Electric Club Car


All times are GMT -5. The time now is 07:09 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.