lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-03-2011, 11:48 AM   #21
Gone Wild
 
sonicj's Avatar
Club Car
 
Join Date: Oct 2010
Location: Panama City, FL
Posts: 1,408
Default Re: Installed trojans last night Batteries not charging..... Or maybe they are?....

you should be going MUCH faster than 10mph... like double that!

just a thought, how fast dos it go backwards?
-sj
sonicj is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-03-2011, 12:03 PM   #22
Getting Wild
 
Join Date: Mar 2011
Posts: 129
Default Re: Installed trojans last night Batteries not charging..... Or maybe they are?....

hmmmm. ill got check it and report back. thanks, Nick
nick731 is offline   Reply With Quote
Unread 08-03-2011, 12:50 PM   #23
Getting Wild
 
Join Date: Mar 2011
Posts: 129
Default Re: Installed trojans last night Batteries not charging..... Or maybe they are?....

ok the speeds are as follows:
foward: 11 mph
reverse: 5-7 mph
uphill: 5-7 mph
downhill: 25-28mph
nick731 is offline   Reply With Quote
Unread 08-03-2011, 01:17 PM   #24
Gone Wild
 
sonicj's Avatar
Club Car
 
Join Date: Oct 2010
Location: Panama City, FL
Posts: 1,408
Default Re: Installed trojans last night Batteries not charging..... Or maybe they are?....

are your tires flat? lol
sonicj is offline   Reply With Quote
Unread 08-03-2011, 06:09 PM   #25
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,025
Default Re: Installed trojans last night Batteries not charging..... Or maybe they are?....

Sounds about right to me for a series car. In stock form they won't get out of their own way.
TahoeDawgZ71 is offline   Reply With Quote
Unread 08-03-2011, 06:44 PM   #26
Getting Wild
 
Join Date: Mar 2011
Posts: 129
Default Re: Installed trojans last night Batteries not charging..... Or maybe they are?....

lol no they are not flat.

ok thanks tahoe dawg. what is the best step foward from here to get me closer to at least 20 mph on the straight aways? thanks! Nick
nick731 is offline   Reply With Quote
Unread 08-04-2011, 09:49 AM   #27
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,025
Default Re: Installed trojans last night Batteries not charging..... Or maybe they are?....

Quote:
Originally Posted by nick731 View Post
lol no they are not flat.

ok thanks tahoe dawg. what is the best step foward from here to get me closer to at least 20 mph on the straight aways? thanks! Nick
Motor and controller upgrade. There's thousands of options out there and one of the site sponsors can hook you up with exactly what you're looking for.
TahoeDawgZ71 is offline   Reply With Quote
Unread 08-04-2011, 03:15 PM   #28
Getting Wild
 
Join Date: Mar 2011
Posts: 129
Default Re: Installed trojans last night Batteries not charging..... Or maybe they are?....

ok thanks tahoe dawg. Looks like im considering full 4 gauge wire, plum quick bandit upgrade, and either the alltrax 400 amp or a rebuilt curtis 480 amp controller. Think this setup is a good idea and will do the trick? what speeds could i expect out of it... thanks! nick
nick731 is offline   Reply With Quote
Unread 08-04-2011, 08:57 PM   #29
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,025
Default Re: Installed trojans last night Batteries not charging..... Or maybe they are?....

Quote:
Originally Posted by nick731 View Post
ok thanks tahoe dawg. Looks like im considering full 4 gauge wire, plum quick bandit upgrade, and either the alltrax 400 amp or a rebuilt curtis 480 amp controller. Think this setup is a good idea and will do the trick? what speeds could i expect out of it... thanks! nick
The bandit won't work for your application. It's a shunt motor. You need a series motor. I'm a dealer tech so honestly I don't have a clue what to tell you as far as aftermarket stuff goes. I leave that to the experts. Call PQ and see what they can do for you. They do series stuff as well, but the Bandit is strictly for a shunt type system.
TahoeDawgZ71 is offline   Reply With Quote
Unread 08-04-2011, 09:16 PM   #30
Getting Wild
 
Join Date: Mar 2011
Posts: 129
Default Re: Installed trojans last night Batteries not charging..... Or maybe they are?....

ok thanks tahoedawg, its cool to have a fellow augusta dweller on here! ill call and see what they can do. thanks, nick
nick731 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
gc8 sams club batteries vs trojans t875 Electric Club Car
07 Club Car Precedent---Lights stopped working after new batteries installed Electric Club Car
Installed new batteries Electric Club Car
97 Club Car 48V DS Charger's Stopped Coming On shortly after New Batteries Installed Electric Club Car


All times are GMT -5. The time now is 04:25 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.