lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-12-2011, 07:56 PM   #11
Not Yet Wild
 
Join Date: Nov 2010
Posts: 26
Default Re: new batts and charger wont charge, charger works on other carts

sorry so long to get back. Had both computers stolen out of my truck.
scantx is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-13-2011, 08:27 AM   #12
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: new batts and charger wont charge, charger works on other carts

Why mess with charger . . you said it works on other cars. Did you do the grey wire test Garminde suggested?
Stevegrmich is offline   Reply With Quote
Unread 08-13-2011, 09:04 AM   #13
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,074
Default Re: new batts and charger wont charge, charger works on other carts

Agreed. The charger works on other carts. Leave it that way Perform the obc bypass test to confirm you need a new computer in the cart.

OBC bypass & Test =
The black wire coming out of charge receptacle has a yellow fuse holder, open it up and connect a jumper from the end coming out of receptacle to the negative on Battery 6 or the last one in series. Plug in the charger if it comes on your OBC is most likely TOAST.
scottyb is online now   Reply With Quote
Unread 08-13-2011, 11:25 AM   #14
Not Yet Wild
 
Join Date: Nov 2010
Posts: 26
Default Re: new batts and charger wont charge, charger works on other carts

I ran a jumper from the fuse boot receptical side to the #6 neg. Plugged in the charger and got nothing. I will try again , perhaps I didn't have a good connection inside the boot.
scantx is offline   Reply With Quote
Unread 08-13-2011, 11:30 AM   #15
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,074
Default Re: new batts and charger wont charge, charger works on other carts

Quote:
Originally Posted by scantx View Post
I ran a jumper from the fuse boot receptical side to the #6 neg. Plugged in the charger and got nothing. I will try again , perhaps I didn't have a good connection inside the boot.
I have clipped the jumper wire on a Phillips screwdriver and shoved the screwdriver into the fuse holder just to see the charger come on.
If this test does not start your known good charger the problem is potentially in the receptacle. Check the big glass fuse on top of the receptacle.
scottyb is online now   Reply With Quote
Unread 08-13-2011, 11:39 AM   #16
Not Yet Wild
 
Join Date: Nov 2010
Posts: 26
Default Re: new batts and charger wont charge, charger works on other carts

I used a larger wire with the end bent so it fit snugly into the fuse boot, and secured the other end to the terminal. Nada. The fuse looks good and when I put the tester on each side I have a signal saying good. The wires in the receptical look good , nothing can be pulled out. I will remove from the cart and inspect more. Sorry if I sound like a broken record. This thing will get fixed. There has to be a logical explination. Thank ya'll for the help.
scantx is offline   Reply With Quote
Unread 08-13-2011, 11:43 AM   #17
Moderator
 
rib33024's Avatar
E-Z-GO
 
Join Date: Apr 2009
Location: FT Lauderdale FL.
Posts: 13,159
Default Re: new batts and charger wont charge, charger works on other carts

When you changed the batteries, the ground cable is still running through the hole in the OBC right??
rib33024 is offline   Reply With Quote
Unread 08-13-2011, 12:09 PM   #18
Not Yet Wild
 
Join Date: Nov 2010
Posts: 26
Default Re: new batts and charger wont charge, charger works on other carts

Yes,sir. It is "plumbed " just like it was. I took the shroud off of the top of where the obc and controler are and all looks and feels fine.
scantx is offline   Reply With Quote
Unread 08-13-2011, 12:11 PM   #19
Not Yet Wild
 
Join Date: Nov 2010
Posts: 26
Default Re: new batts and charger wont charge, charger works on other carts

All functions are working , radio, lights,turn signals,forward and reverse. Just no charging.
scantx is offline   Reply With Quote
Unread 08-13-2011, 01:49 PM   #20
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,074
Default Re: new batts and charger wont charge, charger works on other carts

When you opened the fuse you put your jumper in the receptacle side of the fuse, correct?

I have never seen a good charger not come on for this test?
scottyb is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
DS Club Car Charger wont charge Electric Club Car
charger wont charge at high amps anymore Electric EZGO
Charger wont charge fully Electric Club Car
PowerWise Charger wont charge Electric Club Car
Charger wont fully charge... Electric EZGO


All times are GMT -5. The time now is 07:35 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.