lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-26-2011, 07:24 PM   #1
Not Yet Wild
 
Join Date: Jan 2011
Posts: 54
Default Battery issue

I have a 2008 precedent with Trojan batteries. The cart was running strong until I added distilled water to the batteries. The cart was running great but I noticed some of the batteries were low on water so I added some distilled water to the proper levels. The next day I had played about 12 holes before it started creeping up hills. I usually can play 36 holes without skipping a beat. Did I do something wrong or is this a coincidence it is happening now? Any fix?
clarkgrizwauld is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-26-2011, 08:21 PM   #2
Gone Wild
 
sonicj's Avatar
Club Car
 
Join Date: Oct 2010
Location: Panama City, FL
Posts: 1,408
Default Re: Battery issue

the acid may be stratified at the bottom of the cell. do a couple of equalization charges and see if it doesn't get better.
-sj
sonicj is offline   Reply With Quote
Unread 08-26-2011, 10:26 PM   #3
Not Yet Wild
 
Join Date: Jan 2011
Posts: 54
Default Re: Battery issue

I have fully charged it 3 or 4 times after I added the water and every time I use it, it starts creeping after a very short period of time. I can't figure out why it has never done this before and only started creeping after I added the water.
clarkgrizwauld is offline   Reply With Quote
Unread 08-26-2011, 11:02 PM   #4
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Battery issue

has to be just coincidense......................................8 )
shadowman is offline   Reply With Quote
Unread 08-27-2011, 06:49 AM   #5
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: Battery issue

Have you:
1. Checked pack voltage after charge?
2. Checked individual battery voltages?
3. Checked cell SG's?

One of above may point in direction of problem . .
Stevegrmich is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Charging Issue/ Battery Issue? Electric EZGO
Battery Issue Electric Club Car
Still having a battery issue Electric Club Car
G3 Battery Issue Gas Yamaha
Battery Issue Electric Club Car


All times are GMT -5. The time now is 02:13 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.