lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-29-2011, 02:43 AM   #1
Not Yet Wild
 
Join Date: Jul 2011
Posts: 14
Default Half speed, speed sensor problem?.

Hi Clubcar Buddies.
This weekend i installed the two missing Screws Bearing Retainer on my Clubcar President 2004.
Everything went good but it was much work, i needed to remove the rear axle to be able to install the new screws. I took the chance to change the oil at the same time; I think it was very long time ago.
But unfortunately I got another problem after the installation, the Clubcar accelerates as normal but after 30-40 meters the speed reduced to “half speed”.
I removed the speed sensor, same problem, the speed sensor looks “fine” but I may be broken?
BR
r2000
r2000 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-29-2011, 09:35 AM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,974
Default Re: Half speed, speed sensor problem?.

do a search here there is a simple test you can do to try and confirm if sensor is bad.................................
shadowman is offline   Reply With Quote
Old 08-29-2011, 09:46 AM   #3
Not Yet Wild
 
Join Date: Jul 2011
Posts: 14
Default Re: Half speed, speed sensor problem?.

You mean this test?.

Try and push the car manually and see if the motor braking tries to keep it from "Rolling away" If the sensor is working, it'll try to slow itself down, if it just keeps rolling, it's bad. Make sure you do this test in the "RUN" position. If it's in "TOW" it will definitely roll.
r2000 is offline   Reply With Quote
Old 08-29-2011, 10:05 AM   #4
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,974
Default Re: Half speed, speed sensor problem?.

yes thats the one..................................
shadowman is offline   Reply With Quote
Old 08-30-2011, 05:40 AM   #5
Not Yet Wild
 
Join Date: Jul 2011
Posts: 14
Default Re: Half speed, speed sensor problem?.

Yes it's look like the sensor is broken!.
r2000 is offline   Reply With Quote
Old 08-30-2011, 06:55 AM   #6
Mr. Helper
 
ForBruce's Avatar
Club Car
 
Join Date: May 2009
Location: NY Catskills & Bronx
Posts: 435
Default Re: Half speed, speed sensor problem?.

push the cart in forward and then in reverse..with the key on

does it beep indicating ROLLAWAY if not speed sensor is bad...if it beeps then sensor is good
ForBruce is offline   Reply With Quote
Old 08-30-2011, 08:37 AM   #7
Not Yet Wild
 
Join Date: Jul 2011
Posts: 14
Default Re: Half speed, speed sensor problem?.

Ok, i will try later today.
r2000 is offline   Reply With Quote
Old 08-31-2011, 02:17 AM   #8
Not Yet Wild
 
Join Date: Jul 2011
Posts: 14
Default Re: Half speed, speed sensor problem?.

Yes, the sensor is broken.
I need to buy a new one or fix it with a new Allegro switch.

BR
r2000
r2000 is offline   Reply With Quote
Old 08-31-2011, 07:44 AM   #9
Mr. Helper
 
ForBruce's Avatar
Club Car
 
Join Date: May 2009
Location: NY Catskills & Bronx
Posts: 435
Default Re: Half speed, speed sensor problem?.

speed sensor building..click on link --then look at photos in post #57

Club Car Speed link 4 Precedent Golf Cart SpeedyLink
ForBruce is offline   Reply With Quote
Old 08-31-2011, 10:42 AM   #10
Not Yet Wild
 
Join Date: Jul 2011
Posts: 14
Default Re: Half speed, speed sensor problem?.

Thanks! One question, witch cable color should connect to witch Pin on the Allegro?.
I still waiting for my Allegro A1203..
r2000 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
MCOR? Speed Sensor? Controller? Cart Runs at half speed. Advice, please. Electric Club Car
08 precedent electric speed sensor problem. Cart starts at proper speed then slows . Electric Club Car
Which EZ GO Speed Sensor ? Electric EZGO
Speed Sensor Electric Club Car
half speed Electric EZGO


All times are GMT -5. The time now is 05:29 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.