lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-02-2011, 08:35 PM   #1
Not Yet Wild
 
Join Date: Sep 2011
Posts: 2
Default 2005 Precedent starts of powered, then loses power, reverse always power

Hello, I have a 2005 electric Club Car Precedent cart which has a power problem. When I start driving after it is fully charged it has normal power but after about half a mile or so it loses power and then just goes slowly.

The reverse still has full power (this is a regen cart). It will drive its normal range but very slowly.

the batteries are only a few month old and have been charged at east 50 times.

Somewhere in my internet searching I read about someone with this probem fixing it with a power sensor module. Could this be my problem?
lamontweaver is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-03-2011, 11:25 AM   #2
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: 2005 Precedent starts of powered, then loses power, reverse always power

Look under ( motor speed sensor ) as this is very often the problem with later models like yours is acting? Its mounted on outboard end of motor with a 3 wire plug connecting it to wiring loom.
OLD MEC is offline   Reply With Quote
Unread 09-03-2011, 07:34 PM   #3
Not Yet Wild
 
Join Date: Sep 2011
Posts: 2
Default Re: 2005 Precedent starts of powered, then loses power, reverse always power

Old Mec,
Thank you for taking the time to help, much appreciated.
lamontweaver is offline   Reply With Quote
Unread 09-04-2011, 09:36 AM   #4
Gone Wild
 
OLD MEC's Avatar
Club Car
 
Join Date: Mar 2009
Location: South Texas
Posts: 2,391
Default Re: 2005 Precedent starts of powered, then loses power, reverse always power

Thats what our forum is for helping others, so when possible you can pass info on to the next needy golf cart owner.
OLD MEC is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Cart loses power fast Electric Club Car
My 1995 G14 Loses Power Gas Yamaha
loses power up hill Gas EZGO
Cart loses power Electric EZGO


All times are GMT -5. The time now is 04:34 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.