lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-06-2011, 04:45 PM   #1
Not Yet Wild
 
Join Date: Sep 2011
Posts: 20
Default 2007 Precedent questions/issues

I just picked up a 2007 Club Car Precedent. Overall the cart is in great condition. Batteries do appear to be original and DO have some corrosion.

I am experiencing a blinking battery light as well as the fuse on the charger popping.

I am planning on cleaning and watering the batteries as well as resetting the OBC. I am also going to check all the wiring for cracks, etc. I may also look into testing the rectifier in the charger. Not sure I feel comforatble tackling that, but...

Any other places I should check?

Also, there are 2 wires (16-18 gauge) that are lose. Both appear to be male connectors. One comes off of + of battery 1, the other comes off - of battery 4. Is this for a volt meter?

Cart runs fine aside from not charging properly.
bcampbe7 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-06-2011, 08:55 PM   #2
Not Yet Wild
 
Join Date: Sep 2011
Posts: 20
Default Re: 2007 Precedent questions/issues

Cleaned the batteries. All are showing around 12V except 1. It is showing around 11V. Not sure if that is because I haven't been able to charge the batteries or not.

Rectifier is showing 459mV at all locations. I think that is the culprit. What say the experts?
bcampbe7 is offline   Reply With Quote
Unread 09-07-2011, 09:16 AM   #3
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 2007 Precedent questions/issues

welcome to BGW................you need to get the batteries charged to get good voltage readings......as for the breaker popping can you get another charger to try on your cart to make sure problem is charger and not cart? if it is charger i would think the heatsink and diode and also change the breaker cause once they start tripping it seems they get weak and will keep tripping...........so once you get that sorted out postyour voltage #,s after a full charge.......................................
shadowman is offline   Reply With Quote
Unread 09-07-2011, 09:34 AM   #4
Gone Wild
 
SaltLifeCC's Avatar
 
Join Date: Jun 2010
Posts: 729
Default Re: 2007 Precedent questions/issues

Don't worry about the 2 extra wires. There is a red one coming off battery one and a blue one coming off battery 4 right? Those are put there at the factory for optional use. For example, the OEM light kit harness feeds off the blue wire to get 12v to run lights if you add them.
SaltLifeCC is offline   Reply With Quote
Unread 09-07-2011, 09:42 AM   #5
Not Yet Wild
 
Join Date: Sep 2011
Posts: 20
Default Re: 2007 Precedent questions/issues

Quote:
Originally Posted by shadowman View Post
welcome to BGW................you need to get the batteries charged to get good voltage readings......as for the breaker popping can you get another charger to try on your cart to make sure problem is charger and not cart? if it is charger i would think the heatsink and diode and also change the breaker cause once they start tripping it seems they get weak and will keep tripping...........so once you get that sorted out postyour voltage #,s after a full charge.......................................

Will do. Can I use a car charger and charge the batteries individually?


Quote:
Originally Posted by SaltLifeCC View Post
Don't worry about the 2 extra wires. There is a red one coming off battery one and a blue one coming off battery 4 right? Those are put there at the factory for optional use. For example, the OEM light kit harness feeds off the blue wire to get 12v to run lights if you add them.
Yep, those are the ones. Cool. I figured they were for lights or something like that. Thanks!
bcampbe7 is offline   Reply With Quote
Unread 09-07-2011, 10:24 AM   #6
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 2007 Precedent questions/issues

yes you can use a car charger and since it has 12 volt batteries thats makes it even easier..........just charge each one up 1 at a time........................
shadowman is offline   Reply With Quote
Unread 09-07-2011, 10:33 AM   #7
Not Yet Wild
 
Join Date: Sep 2011
Posts: 20
Default Re: 2007 Precedent questions/issues

Quote:
Originally Posted by shadowman View Post
yes you can use a car charger and since it has 12 volt batteries thats makes it even easier..........just charge each one up 1 at a time........................
Thanks Tom!
bcampbe7 is offline   Reply With Quote
Unread 09-07-2011, 11:28 AM   #8
Gone Wild
 
SaltLifeCC's Avatar
 
Join Date: Jun 2010
Posts: 729
Default Re: 2007 Precedent questions/issues

Once you charge them all up completely and put them back in the cart, put them under load (ride the cart) and then go back and check each battery. When I first got my cart, I found I had a bad battery by doing that. The pack would charge up and each battery would show the proper voltage, but the bad one would quickly discharge, compared to the other ones, after a very short run time.
SaltLifeCC is offline   Reply With Quote
Unread 09-08-2011, 10:15 PM   #9
Not Yet Wild
 
Join Date: Sep 2011
Posts: 20
Default Re: 2007 Precedent questions/issues

Replaced the rectifier and circuit breaker and she is charging like normal now! Thanks for the help!
bcampbe7 is offline   Reply With Quote
Unread 09-21-2011, 12:32 AM   #10
Gone Wild
 
Join Date: May 2009
Posts: 230
Default Re: 2007 Precedent questions/issues

bcampbe7,,, could you be more specific. Are you saying you took the charger apart and somehow diaganosed the problem to the rectifier and the circuit breaker and once you replaced those it worked fine. How did the batteries charge, especially the one that was at 11.xx volts. Did you drive test the batteries as suggested by Saltlife and if so what were the results. You did a lot of good work but to post only "she is charging doesn't help many other people.
trigger1937 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2007 Yamaha Electric-Questions Electric Yamaha
Looking to buy a 2007 cc Precedent.. Any Advice? Electric Club Car
2007 EZ-GO ST 2+2 36v Cart Questions Electric EZGO
2007 Precedent vs DS Electric Club Car
2007 Columbia Par Car Questions Columbia ParCar


All times are GMT -5. The time now is 05:18 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.