lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-22-2011, 09:48 AM   #1
Not Yet Wild
 
securitymikey's Avatar
Club Car
 
Join Date: Sep 2011
Location: New York
Posts: 12
Default slow DS cart

Hi. I have a 95 DS 36 volt cart. I got it about 7 years ago and it ran strong. We used it around the yard but would overload it a lot working the cart hard. One day the motor went and I replaced it with a used one laying around. It ran again but hasn't been the same over time. I checked the batteries doing hydro,load,and volt tests. 4 of them were great (6v+) and I replaced 2 (3v). I noticed the speed coils are almost black and have what looks like rust. I cleaned them off the best I could. The speed controler box looks like everything is moving around fine inside. The cart is just kinda slow and barley gets up hills anymore which is the main problem. Anyone have any ideas on what I can do to make this thing run like it should?
securitymikey is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-22-2011, 09:53 AM   #2
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,069
Default Re: slow DS cart

I would look into a new motor and make sure you have healthy batteries. You can connect the voltmeter to the pack and attack that hill, Post your voltage readings here at a stand still and then the drop on the hill.
scottyb is offline   Reply With Quote
Unread 09-22-2011, 01:18 PM   #3
??????
 
LostHusker's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: South TX
Posts: 8,569
Default Re: slow DS cart

I had a 36V DS cart, had the motor reworked at PQ, 4 gauge wires, ran good, had pretty good speed. Yes it was a resistor cart as well, if that what yours is, but I also had new batteries.
LostHusker is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
slow cart Electric Club Car
Is my cart slow..or is it just me? Gas Club Car
slow cart Electric Club Car
slow Cart Electric EZGO
Cart didn't slow down Electric EZGO


All times are GMT -5. The time now is 10:05 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.