lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-23-2011, 09:42 AM   #1
Getting Wild
Club Car
 
Join Date: Apr 2010
Location: Newport, Tn
Posts: 80
Default 84 DS won't run

I'm working on a 84 DS that will not run. Solenoid does not click, heck I don't even hear the micro switches operate. I jumped the #1 solenid and the # 2 solenoid and the cart moves in both forward and reverse. Is the #1 solenoid different from the other 4 or are they all the same? Before you ask, yes I did check all of the cables and I did stress them. The batteries are weak but I believe this model cart will run with weak batteries to some extent. I also replaceed the #1 solenoid with the #4 solenid and this did not fix the problem. Also checked the key switch and it's good. Any ideas?
tlr6334 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-23-2011, 10:19 AM   #2
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: 84 DS won't run

Batteries would be my first concern before I would rip anything else apart . . .
Stevegrmich is offline   Reply With Quote
Unread 09-23-2011, 10:31 AM   #3
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,093
Default Re: 84 DS won't run

Check the micro switches, are the solenoids being asked to activate & failing to do so or are they not getting the activation signal ?
scottyb is offline   Reply With Quote
Unread 09-23-2011, 11:42 AM   #4
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: 84 DS won't run

as scotty said check the silver box where the micro,s are and check the micro switches......the only solenoid you need to worry about to get the cart to run is the furthest left one drivers side.........thats the master the other 4 are speeds......and its possible also the one you used to swap was bad........why not get 1 new solenoid and at least 1 new micro switch and when you get it running you can check the speed solenoids and replace the ones you need..................if you jumped the master solenoid and cart ran than your issue is either the micro switch that activates it or the master solenoid....................................
shadowman is offline   Reply With Quote
Unread 09-24-2011, 06:17 PM   #5
Getting Wild
Club Car
 
Join Date: Apr 2010
Location: Newport, Tn
Posts: 80
Default Re: 84 DS won't run

The problem was 3 def solenoids and 1 corroded wire under the plastic from the forward reverse switch to the speed microswitches.
tlr6334 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes



All times are GMT -5. The time now is 05:56 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.