lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-08-2008, 10:49 AM   #1
Not Yet Wild
 
PowerWashofVa's Avatar
Club Car
 
Join Date: Mar 2008
Location: Sisal, Mexico
Posts: 26
Default Question

Yesterday a friend and I went for a ride. We went about three miles mostly on gravel and grass. The cart worked fine then it would not hardly go in forward, it did go in reverse!

I felt the motor an (EMP) and it was hot to the touch but did smell. I let it sit a few minutes and it ran fine.

Any thoughts?
PowerWashofVa is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-08-2008, 01:09 PM   #2
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Question

need cart year and voltage, start with basics........batt condition and cables.......everything clean and tight so you have to check it all..............load test batteries if needed and check cells with hydrometer..............................
shadowman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes



All times are GMT -5. The time now is 04:11 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.