lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-06-2011, 08:02 PM   #1
Gone Wild
 
jlmurphy's Avatar
Club Car
 
Join Date: Nov 2010
Location: East to Southeast,Texas
Posts: 186
Default 1999 CC Regen 2 With FSIP 503 need help

I just up graded my CC with a 500 amp FSIP and new batterys. The cart has not preformed much better than my stock controller. But I do understand cycles on batterys and it has gotten a little better. Last night I drove the cart about 6 miles. Got home and put batterys on charge. Today I pushed it out of my shop 10 feet and switched it to run from tow and turned the key on put it in reverse and no beep no movement no click nothing. Checked battery voltage it was 51.34. Pushed it in the shop and pluged in the charger it took a few seconds for the charger to come on and the charge worked its way down in just a few moments unplugged the charge and still nothing. What next.
jlmurphy is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-07-2011, 08:29 AM   #2
Gone Wild
 
jlmurphy's Avatar
Club Car
 
Join Date: Nov 2010
Location: East to Southeast,Texas
Posts: 186
Default Re: 1999 CC Regen 2 With FSIP 503 need help

I also turned the cart on and tried to push it the brake does not try to come on no click no noise.
jlmurphy is offline   Reply With Quote
Unread 10-07-2011, 09:14 AM   #3
Gone Wild
 
Colbyntx's Avatar
Club Car
 
Join Date: Jun 2010
Location: East Texas
Posts: 602
Default Re: 1999 CC Regen 2 With FSIP 503 need help

Hey Jim, long time no see! I bet you have a bunch of beach front at Teledo Bend this year! Man, could be a bunch of things. Your tow/run could have gone bad. No solenoid click could be a bad micro switch or solenoid went out. Did you jack up the rearend and jump the solenoid and see if it would go? Are there any warning lights blinking on the controller when you try it? Did you see if there was power at the solenoid?
Colbyntx is offline   Reply With Quote
Unread 10-07-2011, 11:43 AM   #4
Gone Wild
 
jlmurphy's Avatar
Club Car
 
Join Date: Nov 2010
Location: East to Southeast,Texas
Posts: 186
Unhappy Re: 1999 CC Regen 2 With FSIP 503 need help

Thanks Colby, Yes I need the car to ride on the Lake for there is more land than water. Talk to the factory checked all voltages for him and he said send in the controler. The bad thing is its my Deer lease machine. I will putting the factory 220 amp back in.
jlmurphy is offline   Reply With Quote
Unread 10-09-2011, 06:09 PM   #5
Gone Wild
 
jlmurphy's Avatar
Club Car
 
Join Date: Nov 2010
Location: East to Southeast,Texas
Posts: 186
Default Re: 1999 CC Regen 2 With FSIP 503 need help

Pulled 500 AMP contoller and installed stock controller and selonoid. Back on the road.Will send in 500.Amp tomorrow.
jlmurphy is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
FSIP OR ALLTRAX 500 amp controller Lifted Golf Carts
700 Amp FSIP Speed Controller 0-5k Golf Carts and Parts
500 amp FSIP Controller NEW 4 Club Car Golf Carts and Parts
FSIP Install question Electric Club Car


All times are GMT -5. The time now is 02:29 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.