lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-12-2012, 11:16 AM   #11
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: Batteries Fail to Charge

Quote:
Originally Posted by steitzel View Post
Final answer: After final overnight charging, batteries were at 98% to fully charged...however the cart still did not engage and run. All lights, back-up-sound, blinkers, etc worked but the drive did not engage. I finalized charge individually to each battery to fully charged. Drive still did not engage.

Then worked to reset the OBC but this process did not work per process in posts in this forum. Drive still did not engage.

Then called in advanced technical support....(ie, friend in neighborhood) we then removed the control panel in the battery box to review wiring and ensure no loose wires. When drive activated, it sounded like solenoid would not engage, and after applying advanced technical diagnostics (ie, wiggling wires and finding no loose connections, etc)......drive engaged and cart now runs and charge fine.

Root cause analysis failed but problem solved (for now) and cart continues to run and charge well.
. . . now you know why cart owners have gray hair . . or none at all . . .
Stevegrmich is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-12-2012, 12:09 PM   #12
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: Batteries Fail to Charge

Quote:
Originally Posted by steitzel View Post
Final answer: After final overnight charging, batteries were at 98% to fully charged...however the cart still did not engage and run. All lights, back-up-sound, blinkers, etc worked but the drive did not engage. I finalized charge individually to each battery to fully charged. Drive still did not engage.

Then worked to reset the OBC but this process did not work per process in posts in this forum. Drive still did not engage.

Then called in advanced technical support....(ie, friend in neighborhood) we then removed the control panel in the battery box to review wiring and ensure no loose wires. When drive activated, it sounded like solenoid would not engage, and after applying advanced technical diagnostics (ie, wiggling wires and finding no loose connections, etc)......drive engaged and cart now runs and charge fine.

Root cause analysis failed but problem solved (for now) and cart continues to run and charge well.
Might need to ask for the Super Advanced Tech Support as there might be a loose connection somewhere after all
erict is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Recharging Batteries---so charge recognizes batteries!! Electric EZGO
Golf Cart Fail Compilation Videos
Ultimate Fail. Videos
Changed batteries/batteries won't charge Electric Club Car


All times are GMT -5. The time now is 03:24 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.