lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-10-2011, 10:33 AM   #1
Not Yet Wild
 
Join Date: Aug 2011
Posts: 5
Question 2008 Precedent not moving after brake test

My brakes were squeaking so I applied the brakes lightly and pressed the electric gas pedal to turn them and hopefully clean them up a little. Now the cart makes the usual click when I press the gas and I can hear the servo cycle, but it will not move in forward or reverse. What did I screw up?
northsouth1217 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-10-2011, 10:50 AM   #2
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: 2008 Precedent not moving after brake test

Did you stall the cart?
erict is offline   Reply With Quote
Unread 10-10-2011, 10:52 AM   #3
Not Yet Wild
 
Join Date: Aug 2011
Posts: 5
Default Re: 2008 Precedent not moving after brake test

Yes I did.
northsouth1217 is offline   Reply With Quote
Unread 10-10-2011, 10:59 AM   #4
haveacupofshutthe****up
 
Stevec3201's Avatar
Club Car
 
Join Date: Jun 2011
Location: Viera, FL
Posts: 739
Default Re: 2008 Precedent not moving after brake test

I hope you didn't overload something?? Did you smell anything burning?
Stevec3201 is offline   Reply With Quote
Unread 10-10-2011, 11:11 AM   #5
Not Yet Wild
 
Join Date: Aug 2011
Posts: 5
Default Re: 2008 Precedent not moving after brake test

I only moved about 10 feet. I did not smell anything burning. No smoke. The brakes locked and it stalled then it would not move.
northsouth1217 is offline   Reply With Quote
Unread 10-10-2011, 12:15 PM   #6
Not Yet Wild
 
Join Date: Aug 2011
Posts: 5
Default Re: 2008 Precedent not moving after brake test

Is the procedure for resetting the computer the same for the 2008 as posted in the stickys for the 1997 DS?
northsouth1217 is offline   Reply With Quote
Unread 10-10-2011, 12:41 PM   #7
Gone Wild
 
dougmcp's Avatar
 
Join Date: Mar 2009
Location: Roseville, CA
Posts: 2,757
Default Re: 2008 Precedent not moving after brake test

These carts do not like to be stalled, I would be checking the health of your motor and controller as one or both can expire on a brake stall.
dougmcp is offline   Reply With Quote
Unread 10-10-2011, 01:02 PM   #8
haveacupofshutthe****up
 
Stevec3201's Avatar
Club Car
 
Join Date: Jun 2011
Location: Viera, FL
Posts: 739
Default Re: 2008 Precedent not moving after brake test

Quote:
Originally Posted by northsouth1217 View Post
Is the procedure for resetting the computer the same for the 2008 as posted in the stickys for the 1997 DS?
sorry, I had to remove my comment. Could not help you.
Stevec3201 is offline   Reply With Quote
Unread 10-10-2011, 04:32 PM   #9
Not Yet Wild
 
Join Date: Aug 2011
Posts: 5
Default Re: 2008 Precedent not moving after brake test

Found the problem. Positive lead on the 1st battery was broken but still resting in a way that was not easily noticed (always start with the obvious). I guess when applying the brakes and gas at the same time it could have gotten over heated and broken as it was a little corroded. Installed a new cable end cleaned and protected all connections and all is well. Thanks for the replies-
northsouth1217 is offline   Reply With Quote
Unread 10-11-2011, 08:22 AM   #10
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: 2008 Precedent not moving after brake test

Quote:
Originally Posted by northsouth1217 View Post
Found the problem. Positive lead on the 1st battery was broken but still resting in a way that was not easily noticed (always start with the obvious). I guess when applying the brakes and gas at the same time it could have gotten over heated and broken as it was a little corroded. Installed a new cable end cleaned and protected all connections and all is well. Thanks for the replies-
Easy fixes are the best! . . .
Stevegrmich is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
2008 CC Precedent Electric Club Car
2008 cc precedent won't go Electric Club Car
2008 Precedent Electric Club Car
2005 Club Car Precedent Electric Not Moving Electric Club Car
2008 YDRE Brake Pedal Adjust? Electric Yamaha


All times are GMT -5. The time now is 06:22 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.