lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-18-2011, 01:28 PM   #1
Gone Wild
 
Mr.ken's Avatar
Club Car
 
Join Date: Oct 2010
Location: Southwest florida
Posts: 311
Default Messed up my lights, looking for some help.....

My cart is a 98 DS 48 volt. Todays project was installing a unique ignition switch and digital meter(from scottyb). Both are installed and working like they should. I wanted to change the headlights so they only worked with the key on. I jumped a wire from the hot side of the ign switch to what I thought was the correct side of the light switch(with the original wire disconnected). That didnt work, and now none of the lighting works. A a quick look, the only thing I saw in the circuit besides the switch is an inline blade fuse holder near the battery, but the fuse looks intact. So, Im looking for help getting them working like they should again, and if possible only with the key on. Is there anything else in the circuit besides the switch, and fuse???? Im stopping for the day because my back is aching but I'll be back out tomorrow and any ideas or suggestions are greatly appreciated.........Thanks
Mr.ken is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-18-2011, 01:37 PM   #2
??????
 
LostHusker's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: South TX
Posts: 8,569
Default Re: Messed up my lights, looking for some help.....

It kinda sounds like you took 48v straight to your lights, if that was the case you have burned the bulbs.
LostHusker is offline   Reply With Quote
Unread 10-18-2011, 01:39 PM   #3
??????
 
LostHusker's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: South TX
Posts: 8,569
Default Re: Messed up my lights, looking for some help.....

This unique key, was it a ezgo key 3 position switch?
LostHusker is offline   Reply With Quote
Unread 10-18-2011, 02:02 PM   #4
Gone Wild
 
Mr.ken's Avatar
Club Car
 
Join Date: Oct 2010
Location: Southwest florida
Posts: 311
Default Re: Messed up my lights, looking for some help.....

It is a 2 position switch. I will pull the bulbs and see if there is power in the sockets
Mr.ken is offline   Reply With Quote
Unread 10-18-2011, 02:12 PM   #5
Gone Wild
 
Mr.ken's Avatar
Club Car
 
Join Date: Oct 2010
Location: Southwest florida
Posts: 311
Default Re: Messed up my lights, looking for some help.....

Just looked and the bulbs are intact
Mr.ken is offline   Reply With Quote
Unread 10-18-2011, 06:43 PM   #6
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,069
Default Re: Messed up my lights, looking for some help.....

I'm with LH on the 48v to the light circuit... Maybe the fuse that looks good isn't? can you test the power at the lights with a meter to see what if anything you are getting ? .... or at the light switch for that same voltage test?
scottyb is offline   Reply With Quote
Unread 10-18-2011, 07:03 PM   #7
Gone Wild
 
Mr.ken's Avatar
Club Car
 
Join Date: Oct 2010
Location: Southwest florida
Posts: 311
Default Re: Messed up my lights, looking for some help.....

I will do some testing in the morning and post what I find. New meter and ignition are awesome Scotty........
Mr.ken is offline   Reply With Quote
Unread 10-18-2011, 07:16 PM   #8
Ban Puppy Mills & Stores!
 
scubabud's Avatar
Club Car
 
Join Date: Dec 2008
Location: SE Florida
Posts: 2,945
Default Re: Messed up my lights, looking for some help.....

I'd change the fuse you spoke about anyway and also look for any other fuses that might be inline with your lights. Lights should have been on either 16 volts, (2 8 volt batteries,) or a 12 volt converter. They are not to be placed on a 48 volt key switch.
scubabud is offline   Reply With Quote
Unread 10-18-2011, 07:25 PM   #9
Gone Wild
 
Mr.ken's Avatar
Club Car
 
Join Date: Oct 2010
Location: Southwest florida
Posts: 311
Default Re: Messed up my lights, looking for some help.....

Quote:
Originally Posted by scubabud View Post
I'd change the fuse you spoke about anyway and also look for any other fuses that might be inline with your lights. Lights should have been on either 16 volts, (2 8 volt batteries,) or a 12 volt converter. They are not to be placed on a 48 volt key switch.



I was about to ask tha question..........I will have to look again in the morning, but it looked like the power came from one 8 volt battery, unless I missed something. I didnt see any converter, but I will look much more closely in the morning when my back is rested. I will check/replace that fuse, then do some voltage tests and see what I find
Mr.ken is offline   Reply With Quote
Unread 10-19-2011, 11:52 AM   #10
Gone Wild
 
Mr.ken's Avatar
Club Car
 
Join Date: Oct 2010
Location: Southwest florida
Posts: 311
Default Re: Messed up my lights, looking for some help.....

Here is what i Know so far........The only thing inline between the battery and the light switch is a fuse. The fuse is good, and there is definitely no power to the lights. There is 12 v to one side of the light switch, when I turn the light switch on, There is no power to the other side of the switch, and I lose power to the input of the switch. I thought it might be a bad switch so I hooked up the ignition switch I just took out, which I know is good, and it does the same thing, So it looks like I either fried something between the switch and lights, or something entirely different. It doesnt look like there are any fuses between the light switch and lights, so where does that leave me???? I guess I can check all of the wiring between the switch and lights and make sure there isnt a short somewhere but other than that Im at a loss............and ideas?????
Mr.ken is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Messed up paint!!! Body and Paint
messed up the cart Gas golf carts
Gas pickup messed up Gas EZGO
It Used to Work, then I Messed With It.......... Electric EZGO
oops it got messed up Electric EZGO


All times are GMT -5. The time now is 05:00 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.