lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-20-2011, 08:37 AM   #11
Not Yet Wild
 
Join Date: Jul 2011
Posts: 10
Default Re: slow club car

The cart does the dame thing in reverse that it does going forward at 3/4 throttle. Under load the voltage goes from 50.15 volts to 47.7 volts and when it reaches the 3/4 position the voltage goes back to the 50 volt range. When I removed the battery caps, I noticed a black film on top of the acid almost like a paste. I have never seen this before. I am charging the batteries now and will check the specific gravity this afternoon.
Thanks,
Bubba
elcombs is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-20-2011, 08:51 AM   #12
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: slow club car

Quote:
Originally Posted by elcombs View Post
The cart does the dame thing in reverse that it does going forward at 3/4 throttle. Under load the voltage goes from 50.15 volts to 47.7 volts and when it reaches the 3/4 position the voltage goes back to the 50 volt range. When I removed the battery caps, I noticed a black film on top of the acid almost like a paste. I have never seen this before. I am charging the batteries now and will check the specific gravity this afternoon.
Thanks,
Bubba
Your battery pack is dropping down to 30% of their output. That's a 70% drop. Looks like a battery issue to me.
erict is offline   Reply With Quote
Unread 10-22-2011, 06:36 AM   #13
Not Yet Wild
 
Join Date: Jul 2011
Posts: 10
Default Re: slow club car

I have a cheap hydrometer but all of the balls floated when I tested the cells. The voltage abviously drops when take off and maintains approximately 48 volts and when it reaches the 3/4 throttle and drops out the voltage goes back to 50 volts. Could it possibly be the MCOR unit out of adjustment?
elcombs is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
91 club car too slow Gas Club Car
slow club car Electric Club Car
Slow! How do I make my club car Gasser go really slow. Gas Club Car
97 club car too slow Electric Club Car
02 club car slow Electric Club Car


All times are GMT -5. The time now is 05:34 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.