lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-17-2011, 03:52 AM   #1
Not Yet Wild
 
Join Date: Oct 2011
Posts: 10
Default Thanks to everyone here, cc 2002 ds runs fine now

The problem was exactly what you all agreed
it was: the single low-voltage, about 6 volts deep
cycle marine battery was replaced with a
used, but still good 8.4 volt unit, and the
problem was solved. This is a 48 volt system,
with 6 times 8volt batteries.

Amazing how many technical problems are
actually quite simple, if you know what to
look for.

I'll know what to look for in the future,
thanks to you guys.

Again, thanks for all the helpful responses!

Paul678 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-17-2011, 06:55 AM   #2
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: Thanks to everyone here, cc 2002 ds runs fine now

Quote:
Originally Posted by Paul678 View Post
The problem was exactly what you all agreed
it was: the single low-voltage, about 6 volts deep
cycle marine battery was replaced with a
used, but still good 8.4 volt unit, and the
problem was solved. This is a 48 volt system,
with 6 times 8volt batteries.

Amazing how many technical problems are
actually quite simple, if you know what to
look for.

I'll know what to look for in the future,
thanks to you guys.

Again, thanks for all the helpful responses!

Great it was resolved . . and inexpensively . .
Stevegrmich is offline   Reply With Quote
Unread 11-17-2011, 07:05 AM   #3
Gone Crazy
 
Join Date: Jan 2007
Location: Chesterfield, Va
Posts: 5,064
Default Re: Thanks to everyone here, cc 2002 ds runs fine now

Thanks for the update and glad to here it was resolved.
Would you also post your outcome in the other thread? that will answer a lot of others questions that find the thread during their search.
crash12888 is offline   Reply With Quote
Unread 11-17-2011, 09:40 AM   #4
Not Yet Wild
 
Join Date: Oct 2011
Posts: 10
Default Re: Thanks to everyone here, cc 2002 ds runs fine now

Quote:
Originally Posted by crash12888 View Post
Thanks for the update and glad to here it was resolved.
Would you also post your outcome in the other thread? that will answer a lot of others questions that find the thread during their search.
Done. And once again, Thank You All!

Paul678 is offline   Reply With Quote
Unread 11-17-2011, 03:43 PM   #5
Gone Crazy
 
Join Date: Jan 2007
Location: Chesterfield, Va
Posts: 5,064
Default Re: Thanks to everyone here, cc 2002 ds runs fine now

Now it is time to have fun and DTWOI!!!

(drive the wheelz off it!!)
crash12888 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Yam G9 runs fine but doesn't charge Gas Yamaha
jumped solenoid runs fine Electric EZGO
2002 Club Car DS 48v. Runs fine then shuts down. Electric Club Car
Runs fine but low power! Gas EZGO


All times are GMT -5. The time now is 09:36 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.