lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-28-2011, 10:08 PM   #1
BPP
Not Yet Wild
 
Join Date: Nov 2011
Posts: 2
Unhappy Replacing speed sensor

I have a 2008 Precedent non g.e. motor which recently started running at about half speed regardless of how far the pedal was depressed. when in neutral it also stopped the warning beeps when i moved the cart. My dealer told me to replace the speed sensor but i'm not sure if i should replace the MCOR at the same time. Checked the batteries and they are fine.
Thank you.
BPP is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-28-2011, 11:36 PM   #2
Dawg Gone Wild
 
TahoeDawgZ71's Avatar
Club Car
 
Join Date: Mar 2010
Location: Golf Car Capital of The World... Augusta, Georgia
Posts: 8,030
Default Re: Replacing speed sensor

MCOR is completely irrelevant to the speed sensor. There is no need to change your MCOR for this problem. It's a speed sensor issue.
TahoeDawgZ71 is online now   Reply With Quote
Unread 11-29-2011, 09:45 PM   #3
Not Yet Wild
 
Join Date: Jul 2011
Posts: 1
Default Re: Replacing speed sensor

I had the same problem with my 08 Precedent. Checked the surface charge on my batteries and one had went bad. Replaced the batteries and the cart still went half speed. Also, no warning signal when I pushed the cart. Installed a new speed sensor today and I am back to full speed now. My cart flies with the new batts. I saw an earlier post that said this could be the problem. Thanks to those who posted this earlier.
kpow23 is offline   Reply With Quote
Unread 11-30-2011, 09:19 AM   #4
Mr. Helper
 
ForBruce's Avatar
Club Car
 
Join Date: May 2009
Location: NY Catskills & South carolina
Posts: 436
Default Re: Replacing speed sensor

you can replace the internal part in the speed sensor for only about $1.55

hollow out the old sensor

solder in the new part ( see photo showing curved side of sensor up )

fill hole with epoxy

part is available
.
http://search.digikey.com/scripts/Dk...ds=620-1012-nd
.
.
Attached Images
File Type: jpg speed sensor hollowed out.jpg (4.0 KB, 88 views)
File Type: jpg speed sensor finished view .jpg (177.3 KB, 25 views)
ForBruce is offline   Reply With Quote
Unread 12-03-2011, 02:15 PM   #5
BPP
Not Yet Wild
 
Join Date: Nov 2011
Posts: 2
Default Re: Replacing speed sensor

Thank's guys. I replaced the speed sensor and everything is back to normal. A+ buggies
BPP is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
MCOR? Speed Sensor? Controller? Cart Runs at half speed. Advice, please. Electric Club Car
08 precedent electric speed sensor problem. Cart starts at proper speed then slows . Electric Club Car
Half speed, speed sensor problem?. Electric Club Car
speed sensor Electric EZGO
Speed Sensor Electric Club Car


All times are GMT -5. The time now is 02:18 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.