lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-05-2011, 02:01 PM   #21
Not Yet Wild
 
Join Date: Dec 2011
Posts: 19
Default Re: Removed & cleaned batteries, now won't go?

Thanks. The thing that throws me is the fact that when I hooked everyting back up and turned it on, it worked in reverse. When I tried to change to forward it wouuld not go. It acted like it does when you try to change directions wihout taking your foot off the pedal. I learned a while back that you have to completely take your foor off the petal when changing to forward or it stops. I don't know what that mechanism is, but could that be what is failing now? If "SONICJ" is right, would that cause my charger not to work? It "came on" which tells me it knew that it needed charging and there was enough charge there for it to work, but it didn't register any amps.
Once before, my batteries were so low that the charger would not come on. I had to "charge" each battery separately for a few minutes with a 12v car charger to get it to start.
I don't have headlights or anything now. It acts as though it has completely run down now. Now I measure zero when I test the charge across all bateries. It must have discharged itself overnight. Sounds like a short or big drain somewhere.
royr is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-05-2011, 02:07 PM   #22
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Removed & cleaned batteries, now won't go?

if everything was working proper before you did the battery swap my money is on something you did and your missing it..............been there and done that................you need to go over everything nice and slow and go over it again......it only takes 1 wire or cable to mess everything up........unless there was something wrong before hand your gonna find it just be patience sit and look at it look at every wire and cable...............in the stickies theres are basic diagrams that should help you at least make certain batteries are all correct......in the stickies its the last one down itsays C.C. elec. wiring diagrams theres a 95 to 03 diagram batteries will be wired just like yours.........................................



Electric Club Car wiring diagrams
shadowman is offline   Reply With Quote
Unread 12-05-2011, 02:23 PM   #23
Not Yet Wild
 
Join Date: Dec 2011
Posts: 19
Default Re: Removed & cleaned batteries, now won't go?

Quote:
Originally Posted by shadowman View Post
if everything was working proper before you did the battery swap my money is on something you did and your missing it..............been there and done that................you need to go over everything nice and slow and go over it again......it only takes 1 wire or cable to mess everything up........unless there was something wrong before hand your gonna find it just be patience sit and look at it look at every wire and cable...............in the stickies theres are basic diagrams that should help you at least make certain batteries are all correct......in the stickies its the last one down itsays C.C. elec. wiring diagrams theres a 95 to 03 diagram batteries will be wired just like yours.........................................



Electric Club Car wiring diagrams
The sticky at
http://www.buggiesgonewild.com/attac...950348vuv0.jpg
does look like my situation and shows that there is no wire directly from the receptacle to #6 Neg post, as I stated already. Could the Forward/Reverse switch be the culprit?
royr is offline   Reply With Quote
Unread 12-05-2011, 04:53 PM   #24
Gone Wild
 
sonicj's Avatar
Club Car
 
Join Date: Oct 2010
Location: Panama City, FL
Posts: 1,408
Default Re: Removed & cleaned batteries, now won't go?

Quote:
Originally Posted by royr View Post
The sticky at
http://www.buggiesgonewild.com/attac...950348vuv0.jpg
does look like my situation and shows that there is no wire directly from the receptacle to #6 Neg post, as I stated already. Could the Forward/Reverse switch be the culprit?
hmm, not sure why unreadable diagrams are in the sticky.... here's one that doesn't suck. (97 ds 48v but should be relevant)

Quote:
Now I measure zero when I test the charge across all bateries. It must have discharged itself overnight. Sounds like a short or big drain somewhere.
measure the voltage of each battery. are they in fact dead? if you had 0 amps on the charge meter yesterday and today the battery pack is totally dead, something is backwards or shorted..
-sj
Attached Images
File Type: jpg cc48v.jpg (351.0 KB, 9 views)
sonicj is offline   Reply With Quote
Unread 12-05-2011, 05:19 PM   #25
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Removed & cleaned batteries, now won't go?

thats why i said a few post ago forget about that wire it dosn,t go on the battery................could it be the F&R ?? yes but if it worked before hand i would think its ok...................................
shadowman is offline   Reply With Quote
Unread 12-06-2011, 12:57 AM   #26
Medicare Recipient
E-Z-GO
 
Join Date: Jun 2011
Location: West Michigan
Posts: 3,543
Default Re: Removed & cleaned batteries, now won't go?

Did you check the fuse in the Sense Lead (gray wire from charger receptacle to OBC)??
Stevegrmich is offline   Reply With Quote
Unread 12-06-2011, 07:54 AM   #27
Gone Wild
 
glassk's Avatar
Club Car
 
Join Date: Dec 2011
Location: Hampton, GA
Posts: 441
Default Re: Removed & cleaned batteries, now won't go?

http://www.alltraxinc.com/files/Doc1...ub-Car-OBC.pdf


have you tried resetting the OBC
glassk is offline   Reply With Quote
Unread 12-06-2011, 09:53 AM   #28
Not Yet Wild
 
Join Date: Dec 2011
Posts: 19
Default Re: Removed & cleaned batteries, now won't go?

Quote:
Originally Posted by glassk View Post
Will that work if my batteries are completely discharged? They seem to have discharged by themselves and I cannot charge them back because of my problem.
royr is offline   Reply With Quote
Unread 12-06-2011, 09:57 AM   #29
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Removed & cleaned batteries, now won't go?

what kind of voltage in each battery???.................................
shadowman is offline   Reply With Quote
Unread 12-06-2011, 10:29 AM   #30
Not Yet Wild
 
Join Date: Dec 2011
Posts: 19
Default Re: Removed & cleaned batteries, now won't go?

Quote:
Originally Posted by shadowman View Post
what kind of voltage in each battery???.................................
Now I read 8v across each battery and 48v across all!
I tried the OBC reset proceedure, but nothing happened. The F/R buzzer did not buzz. When I put the Neg cable back on, nothing happens. I connected the charger again, but it does not come on. When I turn on the switch, I get no reading on my charge meter, and no headlights.
royr is offline   Reply With Quote
Reply

Tags
batteries wiring
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Removed oil injection-question Gas EZGO
Removed Mfg tag Extreme DC!
Cleaned Batteries - Cart does not work Electric EZGO
Wires removed... Not important, are they? Electric Club Car
Windshield scratches removed Electric Club Car


All times are GMT -5. The time now is 12:16 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.