lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-20-2011, 01:32 PM   #1
Not Yet Wild
Club Car
 
Join Date: Jan 2009
Location: Houston, Tx.
Posts: 55
Default Dead Batteries/Cart will not go

OK. Someone please make me feel better and tell me I did not mess something up. I knew the batteries were old and needed to be changed sooner or later and the time has come. The wife and I took the cart out and a mile from the house, it died. Completly died. No movement whatsoever. It was a gradual loss but we didnt feel like walking so we just drove it until it stopped. We got it home and the batteries will not charge any higher than 49.5v. My question is this:

At 49.5v, should the cart move at all or make any noises? When I hit the accelerator, NOTHING happens. I do not hear any noises at all and it doesnt even act like it wants to do anyrhing.

Is this normal? I am hoping I can just replace the batteries and all is well. Is there somethign else I should look at? Is there qa minimum voltage requirment before anyrhing happens?

I am not sure if it matter but it has an Alltrax DCX controller, solenoid etc modifications.
teckersley is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-20-2011, 02:13 PM   #2
Gone Wild
 
DOOmsman's Avatar
Yamaha
 
Join Date: Jul 2008
Location: Reddick IL
Posts: 10,985
Default Re: Dead Batteries/Cart will not go

Please when posting state the model and year of your cart.
It seems you will have to bring the batteries up with a automobile charger and then charge them with the cart charger to test the cart,
DOOmsman is offline   Reply With Quote
Unread 12-20-2011, 02:15 PM   #3
Not Yet Wild
Club Car
 
Join Date: Jan 2009
Location: Houston, Tx.
Posts: 55
Default Re: Dead Batteries/Cart will not go

Quote:
Originally Posted by DOOmsman View Post
Please when posting state the model and year of your cart.
It seems you will have to bring the batteries up with a automobile charger and then charge them with the cart charger to test the cart,
I did that. Even with the cart charger on, they only get to 49.5 volts so I know they are bad but I am curious whether or not I should be hearing or seing "any" movement in the car at that voltage.

Its a 2005 Precedent
teckersley is offline   Reply With Quote
Unread 12-20-2011, 03:35 PM   #4
Gone Wild
 
Down South's Avatar
Club Car
 
Join Date: Aug 2011
Location: La but staying in Houston most of the time
Posts: 554
Default Re: Dead Batteries/Cart will not go

You should get movement with 49.5 Volts. Can you check the pack voltage when you press the accelerator to see if it drops? If it does drop, what is the voltage? If the voltage doesn't drop, you have another problem. Maybe a bad solenoid?
Down South is offline   Reply With Quote
Unread 12-20-2011, 04:19 PM   #5
Gone Wild
 
Scooter B's Avatar
E-Z-GO
 
Join Date: Jan 2011
Location: Southeast Louisiana
Posts: 596
Default Re: Dead Batteries/Cart will not go

It's something more than the batteries, if you are getting 49 V, it should do something. I recently did that, went a little too far with a 4 man load, tried limping back while everybody else walked, but killed it dead, towed it home, plugged it in and went to bed, next morining, I was fully charged and rolling again!
Scooter B is offline   Reply With Quote
Unread 12-20-2011, 04:31 PM   #6
Moderator
 
rib33024's Avatar
E-Z-GO
 
Join Date: Apr 2009
Location: FT Lauderdale FL.
Posts: 13,155
Default Re: Dead Batteries/Cart will not go

Are you trying to get it to move with the charger plugged in to the cart ??? 49.5 on a 48volt cart, is this 49v with the charger on or off??,
rib33024 is online now   Reply With Quote
Unread 12-20-2011, 07:07 PM   #7
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Dead Batteries/Cart will not go

need to test the batteries under a load voltage means nothing if they fail under load however solenoid should click and if it isn,t maybe it went bad...........................
shadowman is offline   Reply With Quote
Unread 12-20-2011, 07:23 PM   #8
Not Yet Wild
Club Car
 
Join Date: Jan 2009
Location: Houston, Tx.
Posts: 55
Default Re: Dead Batteries/Cart will not go

Ok. I just went out and checked again. Batteries definitely bad as they now only have 48.5v. I don't have a tester for testing under a load. The charger is not plugged into the cart. The reverse buzzer sounds but there is no movements or sounds of any sorts in forward or reverse other than the reverse buzzer. The alltrax contoller has a solid green light which is I think the indicator that it is OK.

Any ideas?
teckersley is offline   Reply With Quote
Unread 12-20-2011, 07:27 PM   #9
Gone Wild
 
erict's Avatar
Club Car
 
Join Date: Sep 2011
Location: East Michigan
Posts: 1,305
Default Re: Dead Batteries/Cart will not go

Quote:
Originally Posted by teckersley View Post
Ok. I just went out and checked again. Batteries definitely bad as they now only have 48.5v. I don't have a tester for testing under a load. The charger is not plugged into the cart. The reverse buzzer sounds but there is no movements or sounds of any sorts in forward or reverse other than the reverse buzzer. The alltrax contoller has a solid green light which is I think the indicator that it is OK.

Any ideas?
How are you testing the batteries that they have only 48.5v?
erict is offline   Reply With Quote
Unread 12-20-2011, 07:36 PM   #10
Not Yet Wild
Club Car
 
Join Date: Jan 2009
Location: Houston, Tx.
Posts: 55
Default Re: Dead Batteries/Cart will not go

Quote:
Originally Posted by erict View Post
How are you testing the batteries that they have only 48.5v?
voltmeter with positive on first batter + terminal and neg lead on last battery - terminal
teckersley is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
EZGO electric cart dead after new batteries Electric EZGO
Dead Batteries Help please. Electric EZGO
They say the batteries are dead, can I refurbish, by one or two? Electric EZGO
36 volt batteries dead Electric Club Car
EZGO Batteries dead Electric EZGO


All times are GMT -5. The time now is 08:59 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.