lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car
Electric Club Car Electric DS, and Precedent golf cars



Post New Thread  Reply
 
Thread Tools Display Modes
Old 12-26-2011, 04:22 PM   #1
Not Yet Wild
 
Join Date: Dec 2011
Posts: 3
Default Club car 2000 Ingersoll-Rand

Club car starts fine with a lot of power. Then after say 2 miles starts slowing down. Then gets slower, and then stops. Charger seems to be working fine. Charges and shuts off on it's own. There's no other problem's with the machine such as lights and the reverse works fine.. Just runs out of electric. Batteries are 2 years old? What can I do??

Tks, Bob
Bobhelp is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 12-26-2011, 07:14 PM   #2
Not Yet Wild
 
quikbike's Avatar
Club Car
 
Join Date: Oct 2011
Location: Maine
Posts: 45
Default Re: Club car 2000 Ingersoll-Rand

sounds like a dead cell. check the batteries after it slows down and an 8 will show 6 something or less if there is a bad cell in it. Replace the bad one and off ya go.
quikbike is offline   Reply With Quote
Old 12-27-2011, 08:11 AM   #3
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,973
Default Re: Club car 2000 Ingersoll-Rand

clean all conncetions, make sure they are tight and then test and load test batteries......................also take SG readings from all cells, if your not sure post all your #,s we,ll help out.............................
shadowman is offline   Reply With Quote
Old 12-27-2011, 08:42 AM   #4
Not Yet Wild
 
Join Date: Dec 2011
Posts: 3
Default Re: Club car 2000 Ingersoll-Rand

Hello

Tks for the info.. I will give that a try... Sounds to simple, but that's good for me.. I'm not that big on playing with tools... Have a Happy New Year. Will get back with the results... Bob :-)
Bobhelp is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric Club Car


Thread Tools
Display Modes


Similar Threads
Thread Forum
Ingersoll Rand Gas Engine? Gas Club Car
GOT SPEED 4 a Pioneer 1200? (Ingersol Rand) Gas EZGO
my 2000.5 club car Gas Club Car
club car 2000 Gas Club Car
Look for a 2000.5 and up Club Car top Golf Carts and Parts


All times are GMT -5. The time now is 05:46 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.